Database Requirements

Supported Database Products

If Infopark CMS Fiona is used together with the Rails Connector for CMS Fiona, only MySQL is supported. Otherwise, the following operating systems/database combinations are supported.

These requirements apply to the current version of CMS Fiona. Refer to Database Requirements for Previous Fiona Versions as needed.

Database Linux Windows
Oracle 11g, 12c 11g, 12c
MySQL 5.5.x from Version 5.5.29.
5.6.x
-
Microsoft SQL Server - 2012
SQLite The version included in the product package

The database versions given above refer to the database client installed on the Fiona server. Fiona uses the libraries of the database client to communicate with the database server. The database client may be able to communicate with several database server versions. However, as a rule of thumb, the versions of the database server and the database client should be the same.

On 64-bit operation systems, the database client used must be a 32-bit version because Infopark CMS Fiona is a 32-bit application.

Infopark recommends using an Oracle or MySQL database.

Further Database Requirements

MySQL

The MySQL Database must be operated on a 64-bit system. Otherwise, large BLOBs (binary large objects) cannot be managed. Please also observe the notes on MySQL in the integration documentation.

SQLite

SQLite is not suitable for productive use and is supported by Infopark for testing purposes only.