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1
1  Introduction

Infopark CMS Fiona is a Web Content Management System for enterprises. It is mainly used for

producing HTML pages and publishing them in the World Wide Web. However, Fiona can also be used

for a variety of other tasks, for example for managing a large number of documents or image files.

The editorial system of the CMS, i. e. the Content Navigator, can be operated using a web browser. The

editor’s and layouter’s work is made easier by means of the professional search engine by Autonomy

(formerly Verity) running in the background, several applications for editing HTML text, and the

possibilty to integrate local applications for content editing. Workflows and the user-specific task list

help to structure your work and assure the quality of the results.

In Fiona, the output (HTML, XML, or other text formats) is generated and controlled by means of

layout files (in short: layouts). The layouts can be designed in way that enables editors to input content

without having to know anything about HTML. The layout files generate the layout of the pages and

insert content at the places designed for it. Layout and content are stored in separate files. By this

means, the layout of any number of pages can be influenced by changing a single layout file.

The documents in this section describe how editors can create and edit content using the Content

Navigator. The explanations in this online manual refer to the English-language user interface

with the default settings of the Content Manager. The explanations are neutral with respect to the

operating system and the browser used. If problems arise with one of these products, please consult

the respective manual.
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2
2  Logging in to the Content Manager

2.1  Opening the Start Page

Before logging-in to the Content Navigator, i.e. the editorial system of Infopark CMS Fiona, please

ensure that the client-side system requirements are met. They can be found in the installation

documentation.

You also require a network connection to the server on which the CMS is running, plus the URL of the

Content Management Server, your user name, and your password.

Start your browser and enter the access URL or select a previously set-up bookmark. The following log-

in page is displayed:

Please enter your user name and your password, observing upper and lower case. Hit the Enter key or

click the green arrow button to confirm your input.

If the data you entered are correct, your starting page (configurable in your preferences) is displayed.

If logging-in fails even after several attempts, please ask your administrator for help.

Please note that the maximum number of users simultaneously logged-in to the CMS depends on the

number of available licenses. If all licenses are in use a corresponding error message is displayed.

http://www.infopark.com/1215311/02-Client-side


Logging in to the Content Manager

Editing Content – © 2011 Infopark AG 11/101

2.2  Selecting an Action

The default starting page is the tree view of the CMS folder hierarchy. If the wizard selection page is

your starting page, you can select here one of the wizards the administration has set up for you:

Select one of the actions offered to begin your work with the CMS. Please note that the screenshot

above is only meant for illustration and that it probably does not show the actions available to you.

2.3  Logging off and logging in again

Please log out of the Content Manager when you leave your workplace. Otherwise unauthorized users

have access to the system and can change data in your name.

Please use the log-out button displayed on all main pages of the Content Navigator or the

corresponding command in the File menu to log out:

Logout button

2.4  Select character encoding

If accents and other "special characters" are not displayed correctly in your browser, please set the

character encoding of your browser to UTF-8 or enable the automatic encoding detection feature if

available.

2.5  Personal Preferences

Your personal preferences, such as the language of the user interface or your password, can be

changed using the Personal Preferences menu item. This item can be found in the Extras menu.
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3
3  The Main Window of the Content Navigator

The main window of the Content Navigator, which is normally displayed directly after logging in,

consists of a menu, a toolbar, a path navigation, and the display area:

The menu, the toolbar, and the path navigation can be hidden if desired by clicking the arrow in the

gray bar below the path navigation.

For the display area, one of several views can be selected. In the screenshot above, the preview can be

seen in which you can navigate and edit individual elements using markers.

Next to the preview, the following views are available:

• Tree view

• Column view

• List view

• Thumbnail view

• Details view

The tree view and the column view are complemented by an overview of important properties of the

currently selected file. In this overview, the name and the title of the file, for example, can be found:
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4
4  Hierarchy Display

In Infopark CMS Fiona, several ways exist to display files: hierarchically as a tree or in the form of

several columns as well as a list or as thumbnails. These display possibilities are described in the

following sections.

Additionally, a file can be selected in the Content Navigator by specifying in the browser the file path

as part of the URL in the following manner:

http://my.fiona:8080/NPS/p/b?request=object_request&object_path=/en/news

Use your server name instead of my.fiona and the path of the file to display instead of /en/news.

The complete path of the selected file can be seen from the path navigation located below the

toolbar. You can click a part of this path to select the folder concerned:

4.1  Tree View

4.1.1  Tree View in Version 6.0

Tree-view icon in the toolbar

In the tree view, folders and other files are displayed like in a file manager. Folders can be opened by

clicking the corresponding array icon. Several subtrees can be open at the same time. When a file in

the hierarchy is clicked, an overview of important file and version fields is displayed on the right-hand

side.

At the top right-hand corner a button for switching to the full details view can be found. In the details

view a corresponding button allows you to switch back to the overview:

Details/Overview Icons
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Show Details

Show Overview.

File Types

The following file types exist:

Folder

This file type structures the file hierarchy. Folders have a main content (HTML) and can

contain fields, just as the other file types. Folders can be opened and closed by clicking the

corresponding array icons.

Document

Files of this type have a main content. Converted files are mostly stored in documents.

Layout

A layout file serves to generate web pages or parts of web pages from folders or documents.

Image

Files of this type contain images suited for the web (GIF, JPG, od PNG images)

Resource

Resources are files that can have any content. They are mostly used for providing

downloadable files on the web site.

For a detailed description of the function of files in Infopark CMS Fiona see Files.

File Versions

In the Content Navigator, the versions of a file are marked as follows:

Draft version

The file has a draft version and no released version.

Draft version and released version

The file has a draft version and a released version.

Released version

The file has a released version and no draft version.

From version 6.5.0 inactive files, i.e. files that have no versions or are temporally inactive, are displayed

in weaker colors, taking into account the version display mode you selected. Inactive files can also be

hidden.
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4.1.2  Tree View in Version 6.5

Tree view icon in the toolbar

In the tree view, folders and other files are displayed like in a file manager. Folders can be opened and

closed by clicking the corresponding array icon:

Several subtrees can be open at the same time. When a file in the hierarchy is clicked, an overview of

important file and version fields is displayed on the right-hand side.

In the toolbar, a button for switching to the full details view can be found:

Details view icon in the toolbar

File Types

The following file types exist:

Folder

This file type structures the file hierarchy. Folders have a main content (HTML) and can

contain fields, just as the other file types. Folders can be opened and closed by clicking the

corresponding array icons.

Document

Files of this type have a main content. Converted files are mostly stored in documents.

Layout

A layout file serves to generate web pages or parts of web pages from folders or documents.

Image

Files of this type contain images suited for the web (GIF, JPG, od PNG images)
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Resource

Resources are files that can have any content. They are mostly used for providing

downloadable files on the web site.

For each file type, corresponding mirror files may exist. These files are marked with a small red arrow.

Example:

Mirror document

Represents a mirror document whose original is located elsewhere in the folder hierarchy.

File Versions

In the Content Navigator, the versions of a file are marked as follows:

Draft version

The file has a draft version and no released version.

Draft version and released version

The file has a draft version and a released version.

Released version

The file has a released version and no draft version.

From version 6.5.0 inactive files, i.e. files that have no versions or are temporally inactive, are struck

through:

Deactivated folder

The folder is temporally invalid or neither has a draft version nor a released version.

The version view mode you selected is taken into account. If, for example a file that has a released

version has been deactivated, it now has a deactivated draft version. The released version, however, is

still active and is not marked as deactivated if you have selected to display released versions by means

of the display options. Deactivated files can also be hidden.

4.2  Column View

Column view icon in the toolbar.
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In the column view the files are displayed in columns. In the second column the files are listed that are

contained in the folder marked with a different colour in the first column. This applies analogously to

the other columns.

If the selected file is a folder, the column containing it is automatically shifted to the left so that

the last part of the path of the files contained in the folder can always be seen from the columns

displayed.

The marked files in the columns denote the last parts of the path of the file currently selected. An

overview of the most important file and version fields of this file is displayed on the right-hand side of

the Content Navigator window.

4.3  List View

List view icon in the toolbar

In the list view all files in a folder are displayed as a list. In the navigation below the toolbar, click

the name of a folder to have its contents displayed in the list. If you click a folder in the list itself, this

folder is opened in the list view.

In order to change the sorting direction from ascending to descending and vice versa, click Name in the

list’s head.
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In the list view, any number of files can be selected by means of the check boxes to the left. Click the

checkbox in the list’s head to select all files in the list.

To the selected files, the workflow commands from the Edit menu can be applied. If a workflow

command cannot be applied to one or more of the files, a corresponding message will be displayed.

Using the list view, any number of files in a folder can be comfortably deleted by selecting the files and

choosing Delete from the Edit menu.

4.4  Thumbnail View

Thumbnal view icon in the toolbar

In this view the files contained in the folder currently selected are displayed as thumbnails (small

images). The thumbnail view is useful especially for folders containing many image files.

If one of the images is selected, an overview of the file’s most important file and version fields is

displayed on the right-hand side.

In the navigation below the toolbar, click a folder name to display its contents as thumbnails. Clicking

a folder in the thumbnail view itself will cause this folders contents to be displayed in the thumbnail

view.
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5
5  Details View

The properties of a file can be viewed in the form of an overview or in the details view.

5.1  Overview

The overview is displayed when the tree view or column view or thumbnails are active (see Tree View

or Column View or Thumbnails, respectively).

• From version 6.5.0 you can switch to the details view by means of the menu or the toolbar.

Details view icon in the toolbar

• Up to version 6.0.x a button for switching to the details view can be found in the top right-hand

corner. In the details view a corresponding button for switching back to the overview is available:

Details/Overview Icons

Show Details

Show Overview

The display of the field values of the selected file's version (see Choose view) adapts itself to the file

type. With images, for example, their height and width, with documents the beginning of their main

content, among other things, is displayed.

5.2  Details

In this area of the Content Navigator, the details of the currently selected file are displayed. This area is

divided into several sections that are presented as tabs.

The way the content is displayed in the overview as well as on the details tabs can be configured by an

administrator. Therefore it might be that the following descriptions of the overview and the tabs do

not fully correspond to the display in your Content Navigator.
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5.2.1  Details

Next to important file and version fields the access permissions of the logged-in user with respect to

the currently selected file are displayed:

Access permission

Read version Users to whom this permission has been given are permitted to view all the
fields of the file and its versions.

Edit draft version This permission allows users to modify the field values of a file’s draft version.

Administer file This permission is required for the following actions: delete, rename, or
move the file; modify the file format, workflow, do not publish fields; release
independently of a workflow, unrelease; grant or withdraw other users access
permission. To delete a file that has never been released, the Edit draft version
permission is sufficient.

Create files This permission only applies to folders. It is required to be able to create files in
the folder.

Additionally, in this area, the fields of the version are displayed, divided into field groups.

The fields and the field groups are customer-specific, i. e. might have been set up by an administrator.

Editing a File Field

If you have been granted the administration permission for a file, you can edit its file fields such as the

name or the format. To do this, click the corresponding field value. A dialog page whose input fields

depends on the type of the field to edit is then displayed.
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5.2.2  Links / References

Up to version 6.0.3 this tab is labelled Links. From version 6.5.0 it is labelled References.

Links

Here the links are displayed that are contained in the main content or the fields of a file version:

Furthermore the links are displayed that are contained in the versions of other files and point to file

currently selected in the Content Navigator.

Links are always contained in versions. However, they point to files, not to versions of files.

Different types of links exist, image links or text links, for example, that can be located in different

places of the version (in the main content or in HTML fields, for example). The type of a link is

indicated by an icon displayed in front of the link path.

If you have the permission to edit the draft version of a file, you can click a link contained in it in order

to edit it. See Edit Links.

For links contained in the version, click the arrow icon behind it to switch to the linked file. For links

pointing to the selected file, the link leads to the file in whose draft version it is contained.

Mirror Files

From version 6.5.0, the mirror files of the file concerned are also displayed on this tab if the file is an

original file. With mirror files, you can find here a reference to the original file.

The references to the mirror files or the original file, respectively, are linked as well so that you can

comfortably navigate to them as desired.

5.2.3  Sorting

The files contained in a folder can be sorted for the purpose of displaying them in a certain order in

automatically generated lists.

The criteria that can be used for sorting files are the values of fields such as Name, Title, or Last

Change. You can view these criteria on the Sorting tab.
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If you are permitted to modify the the draft version of the folder (i. e. if you have write permission to

it), you can select different fields as sorting criteria (if required, the version needs to be taken over for

editing first):

You can specify up to three criteria so that the files are sorted by the next criterion if the values

of a criterion are equal. For each criterion you can specify whether the field values are to be

compared numerically or alphanumerically. The value "112", for example, is alphanumerically less and

numerically greater than "99" which causes the files to be sorted accordingly.

The sorting direction determines whether the files are sorted in ascending (smallest value comes first)

or descending order.

The folder whose files are sorted must be released for the sorting to become effective in the preview.

In the Content Navigator, the files are sorted by name or by title, depending on your choice in the

View menu.

5.2.4  Source Code

On this tab, the main content of the file or folder currently selected is displayed as HTML text:

In this view, links can be edited. To do this, click the link tag attribute (src or href, for example). Click

the linked file path, to switch to the file concerned (the link target file).

5.2.5  Administration

On this tab, important file fields as well as status information are displayed. Users to whom the

administration permission for the file concerned has been given can modify the values of file fields.
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Furthermore, file administrators can grant access permissions for the currently selected file to user

groups. The permissions allow its owner to perform the following actions:

Access permission

Read version Users to whom this permission has been given are permitted to view all the
fields of the file and its versions.

Edit draft version This permission allows users to modify the field values of a file’s draft version.

Administer file This permission is required for the following actions: delete, rename, or
move the file; modify the file format, workflow, do not publish fields; release
independently of a workflow, unrelease; grant or withdraw other users access
permission. To delete a file that has never been released, the Edit draft version
permission is sufficient.

Create files This permission only applies to folders. It is required to be able to create files in
the folder.

Read live version This permission can be used in conjunction with the Portal Manager. Among
other features, this NPS component provides document-specific access
permissions for the visitors of your website. The groups to whom this permission
can be granted may be different from those for the other permissions, if this
has been configured like this by the administrator. If a file’s Read live version
permission has been assigned at least one user group, only the respective group
members are permitted to access the document concerned. Otherwise, all visitors
may access it.

If you wish to reassign the groups, to which a permission has been granted, click on them. This will

open a dialog in which the desired groups can be selected or deselected.

5.2.6  Help (up to version 6.0.x)

On this details tab, help texts concerning the selected file are displayed. Administrators can configure

the GUI and thereby adapt the help texts to the file format and type by editing the Velocity files

(*.vm) in the config/inspectors directory.

From version 6.5 this tab is no longer available.

http://www.infopark.com/1214498/07-GUI-Konf
http://www.infopark.com/1214498/07-GUI-Konf
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6
6  Preview

6.1  Preview (Version 6.0)

In the Content Navigator several preview types are available.

Integrated Preview

The integrated preview is displayed inside the current Content Navigator window.

The integrated preview can be opened using the toolbar icon displayed to the left or by
means of the Preview command from the View menu.

The integrated preview exclusively serves for editing content and links from within a realistic view of

the web page inside the Content Navigator window. This can be done by means of editing elements –

small symbols next to text fields and links that can be modified by clicking the corresponding symbol.

In the View options you can specify which layout is to be used for the preview display.

Separate Preview

By means of the toolbar icon displayed to the left, the preview can be opened in a separate
window. In this preview mode no editing elements are available.

The layout that has been specified in the View options is also effective in the separate preview.

Live Preview

The Live preview can be opened by means of the corresponding command from the View menu. It is

displayed in a separate browser window and has the full Portal Manager functionality (in particular

the portlets and the live server read permissions).
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6.2  Preview (from Version 6.5)

The preview can be opened by means of the toolbar button displayed to the left or by
means of the Preview item in the View menu. It is displayed inside the current Content
Navigator window.

The preview is flexible, meaning that you can choose in the view options (Choose view in the View

menu)

• whether you wish to edit content (i.e. whether edit markers are to be available),

• whether the draft or the released versions of the files are to be displayed, and

• which layout is to be used for the preview.

The preview always has the full Portal Manager functionality (in particular, the portlets are functioning

and the live server read permissions are observed).

If you have enabled the edit markers, additional editing possibilities provided by the administrator

might be available to you. Furthermore, you can hide the menu area including the toolbar and the

path navigation to have more space available in the preview area.

By means of the toolbar button displayed to the left, the preview can be displayed in a
separate window, i.e. without having to change the view in the current window. In this
preview mode no editing elements are available. The separate preview has the same
functionality as the integrated preview. However, editing elements are not present, and the
menu is hidden by default.

6.3  Editing Elements (Markers)

Editing elements, referred to as "Action Markers", allow you to edit content (field values and links)

from within the preview. The editing elements are only visible for field values and links if you have the

permission to edit the version in which the respective field value or link is contained.

If you hold the mouse pointer over an editing element, the source and target of links or, respectively,

the origin of field values are displayed in a tooltip. Click such an icon to edit the link or field value.

The editing elements in the preview have the following function:

Elements for editing links and field values

Edit a link.

Edit an image link.

Edit the value of a field contained in the previewed version.

Edit the value of a field contained in a version different from the one currently displayed.

http://www.infopark.com/1339941/15-npsgui
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The administrator has the possibility to add further editing elements such as wizards or help texts to

the preview.

In the preview, editing elements are also available for mirror files (from version 6.5.0). The elements

affect the corresponding original files.

http://www.infopark.com/1339941/15-npsgui
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7
7  The Menu

From version 6.5.0: To have more space available in the preview area, you can

hide the menu area including the toolbar and the path navigation by clicking

this bar.

Instead of the menu area a thin bar is then displayed at the top of the page.

Click this bar to make the menu area visible again.

The menu includes the main menu items listed below.

7.1  File

7.1.1  New File (Document, Folder, Image, Resource, Layout)

To create a new file, proceed as follows (independently of the file type):

1. In your preferred view, select the folder, in which the new file is to be created.

2. Select from the menu the command Edit > New and then the file type from the submenu.

3. Specify a file name and the file format on the following page.

4. If required, specify on the next page, Edit version fields, the values of the version fields.

The file name must be unique in the folder, i. e. no other file of the same name may exist. Only the

following characters can be used for names: A-Z, a-z, digits, the underscore, the hyphen and the dollar

sign. If the Content Management Server is running on a Unix system, upper and lower case matters,

under Windows, case is irrelevant. This is the default setting that can be changed by an administrator

(see caseSensitiveObjectNames).

The file format serves as a template for the new file. It mainly determines the type of the new file and

the fields of its versions.

After the new file has been created you will be given the opportunity to edit the values of the most

important fields on a dialog page. These fields correspond to the fields in the base field group which

has been configured by the administrator.

http://www.infopark.com/1214180/01-content
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7.1.2  Import Archive ...

The Import archive... command from the File menu allows you to import a ZIP archive into Infopark

CMS Fiona. For details please refer to the description of the corresponding dialog.

7.1.3  Import File ...

This command from the File menu allows you to import a file from the file system into Infopark CMS

Fiona using a dialog.

The CMS supports importing HTML and other text files, images, and “binary” formats (as so-called

resources). Office documents can be imported as resources and then converted to HTML using the

corresponding command from the File menu.

7.1.4  Convert Office Document to HTML...

Using this menu command, you can convert files that have been imported as ressources to HTML. In

your Infopark CMS Fiona, the command might have been customized in such a way that it can only

be applied to files located in certain folders or that have a particular file format. If in doubt, ask your

administrator for the requirements for converting office resource files.

The HTML text of a converted office document is stored in the main contents of a new folder, located

on the same hierarchy level as the resource containing the original office document. If the converted

document contains images, they can be found as individual images in the new folder. If possible the

converter produces links to the images in the HTML document.

Please note that when the same resource is converted again, the files originally created might be

overwritten without inquiry. Therefore, they should be saved if they are still needed.

7.1.5  Search

The Search command from the File menu opens a dialog with which a detailed search for CMS files can

be performed. For a simple search for files whose name or title contains a given character string you

can use the input field in the Content Navigator's toolbar.

 Search input field of the Content Navigator

7.1.6  Log off from Fiona

This menu command ends your CMS session. The login page ist displayed again.

7.2  Edit

7.2.1  Copy, Cut, Paste

The Content Navigator has a clipboard for copying or moving CMS files from their location in the

folder hierarchy to a different one.
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The clipboard works analogously to the clipboard in many operation systems. The commands for

copying, cutting, and pasting can be accessed via the Edit menu.

In order to copy or cut a single file to the clipboard, select it in the hierarchy view and choose the

corresponding command from the Edit menu.

Several files can be copied or cut by means of the list view. In the hierarchy, select the folder concerned

and check the checkboxes of the files you wish to copy or cut. Then select the desired command from

the Edit menu.

If the clipboard contains files, you can paste them into any folder, provided you have write accesss to

this folder. Also, the layouts of the files to be pasted must be permitted layouts in the target folder.

For each pasted file a draft version is created and a workflow is started. Thus, the files appear on the

task list of the user group initially responsible for them.

If you do not wish to duplicate file content but want to make it available in a different location in the

folder hierarchy instead, you can paste the clipboard contents as mirror files. This feature is available

from version 6.5.0. However, if your website is delivered by a Rails application, mirror files will not

work on the live website.

Files can also be pasted to the folder from which they were copied (but not cut). Since a folder cannot

contain several files of the same name, the Content Manager renames them before it adds them to the

folder. The new name is formed by appending the next available counter to the original name. The

first copy of washington thus becomes washington1, the next one washington2, and so forth. Of

course a file is not renamed if no other file with this name exists in the target folder.

Please note: If files are cut and then deleted, the clipboard will be emptied, meaning that the files are

irrevocably lost.

The clipboard does not contain copies of the files that have been cut or copied but only references to

them. Files that have been cut to the clipboard are only removed after they have been pasted to the

folder hierarchy.

If files are copied or cut to the clipboard, the contents of the clipboard is overwritten with these files.

Thus, nothing can be added to the clipboard.

7.2.2  Deactivate

This command from the Edit menu, which is available from version 6.5.0, serves to remove files

workflow-controlled from the live web presence. This is achived by making them temporally invalid.

The command is only available for active files.

Infopark CMS Fiona deactivates a file by expiring its draft version. For a released file that has no draft

version, a draft version is created as a copy of the released version. This draft version is then expired.

The inactive draft version can be released in accordance with its workflow. An inactive draft version is

always considered complete, meaning that it can be released even if it contains unresolved links, for

example.

If one of the workflow steps Edit or Unrelease is performed after deactivation, the validity period

of the resulting draft version is reset. This means that the draft version is valid from then on for an

unlimited period of time.

Please note that the view you selected in your personal settings determines how deactivated files are

displayed in the tree, column, list, and thubnail view. If, for example, a file has a deactivated released
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version of which a draft version is created, the file is deactivated in the live view while in the editorial

view (in which the draft versions are displayed) it is not.

If you have chosen to have inactive files displayed (using the View > Show files > Inactive files menu

item), they will be displayed striken out:

A file is also inactive if

• the validity period of the version displayed ends in the past or begins in the future,

• it neither has a released nor a draft version (it will then be marked as inactive in all views),

• it has a draft version but no released version and the live-server view was chosen.

You can deactivate files by means of the menu, the toolbar, or via the Tcl interface.

7.2.3  Delete

Using the Delete command from the Edit menu, files can be removed permanently from the folder

hierarchy:

Files can only be deleted by the file administrator, except if you created the file and it has not yet been

committed, signed, or released. In this case, you may delete the file.

Also, files cannot be deleted, if they are the target of one or more links.

7.2.4  Edit Main Content with ...

The main content of a version can be edited using different editors. The following editors are

available:

Editors

Internal editor Simple text editor without WYSIWYG function.

TinyMCE JavaScript-based WYSIWYG editor, available in CMS Fiona 6.8 and
later.

Microsoft HTML Editor Editor based on Microsoft Internet Explorer. This editor is available in
CMS Fiona up to version 6.7.3.

Local application In your personal preferences you can specify a local application for
each file name extension. Normally, local applications are installed on
the client computer. If your configuration is correct, the field value to

http://www.infopark.com/1376334/deactivate
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be edited is saved locally and the corresponding application is started
when the field value is clicked.

HTML Editor Java-based HTML editor (edit-on Pro) with many functions.

The editor you choose for editing the main content is remembered as your standard editor and will

be automatically chosen the next time you edit a file with the same file format (by clicking a linked

field value). You can select the menu command Edit main content with ... at any time to change your

standard editor.

7.2.5  Replace Links to This File

By means of this menu command, which is available from version 6.5.0, the destinations of all links

pointing to the currently selected file can be replaced with a different destination. For this, a dialog

page is used.

7.3  View

7.3.1  Preview (up to Version 6.0.x)

The („integrated") preview displayed in the Content Navigator window allows you to edit links

and field values from within whole pages that almost look like the published web page would.

Additionally, they contain small icons next to links and field values.

If you hold the mouse pointer over an edit icon, the source and target of links or, respectively, the

origin of field values are displayed in a tooltip. Click such an icon to edit the link or field value.

For the integrated preview you can use one of the layout files that can be selected via the View >

Choose view menu command. These layout files are made available by an administrator. Since any

layout can be used, the integrated preview does not necessarily correspond to the preview displayed in

a separate window or to the live-server preview.

It is possible that not all field values or links have icons for editing attached to them. The icons are only

present if you are permitted to edit the version containing the link or field value.

Which versions of the layout files and the files to be previewed are to be used for the integrated

preview can be set by means of the View > Choose view menu command. See Choose view.

The edit icons in the integrated preview have the following function:

Icons for editing links and field values

Edit a link.

Edit an image link.

Edit the value of a field contained in the previewed version.

Edit the value of a field contained in a version different from the one currently displayed.
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Restrictions of the Integrated Preview

When links or redirects are generated or triggered, respectively, the selection in the folder hierarchy

will not be adjusted. This means that the selected file remains selected even if the target of the link or

redirect is a different file.

When frames are used the links will not function as expected because the frame names and targets are

made to work on the live server and not in the integrated preview.

These restrictions do not apply to the preview displayed in a separate window.

Separate Preview and Live Server Preview

As opposed to the inline preview, the live server preview displays the released version as it would

appear on the live server, however without executing special live server functions such as portlets or

search functions. Use the live server preview for this.

Both preview modes are displayed in separate browser windows can be invoked by means of the

corresponding commands in the View menu.

7.3.2  Preview

From version 6.5.0 this menu command opens a preview of the selected file. Up to version 6.0.x, this

preview always contains editing elements (action markers) for content to which you have write access.

From version 6.5, the action markers can be hidden or made visible by means of the corresponding

command in the View menu. The editing elements can be made visible or invisible by means of the

corresponding menu commands in the View menu. The preview is not available for layout files and

deactivated files (from version 6.5.0).

7.3.3  Tree

As the name of this view suggests, the files are displayed hierarchically as a tree. Files of the folder

type structure the hierarchy.

7.3.4  Columns

In the column view the files are displayed hierarchically as columns. Files of the folder type structure

the hierarchy.

7.3.5  List

In the list view the files contained in a folder are displayed as a list. In the list, files can be selected by

means of check boxes so that menu commands can be comfortably applied to several files at once.

7.3.6  Thumbnails

In the thumbnail view, the files contained in a folder are displayed as small images. This view is helpful

when searching an image in an image folder.
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7.3.7  Details (from Version 6.5.0)

This menu command switches to the details view.

7.3.8  Separate Preview

This menu command opens a preview of the selected file in a separate browser window. This display

mode of the web site does not include icons for editing content.

The preview is not available for layout files.

7.3.9  Live Preview

This menu command is available up to version 6.0. It opens the live preview in a separate browser

window, giving you the possibility to check the currently selected file with respect to its look and

functionality. For portlets to be displayed in this preview the Portal Manager must have been

integrated into the live system.

From version 6.5.0 this menu command is no longer present since the preview functions as a live

preview if the corresponding viewing options have been chosen.

7.3.10  Editor's View

This menu command is available from version 6.5.0. It enables the editing elements in the preview,

however it does not activate the preview itself. For this, use the View > Preview menu command if the

preview is currently not displayed.

7.3.11  Hide Menu

From version 6.5.0 this menu command completely hides the menu area (including the toolbar and the

path navigation). Click the small bar at the top of the browser window to make the menu area visible

again.

7.3.12  Displaying Titles or Names

In the View menu you can select whether the names or titles of files are to be displayed in the

hierarchy view of the Content Navigator, i. e. in the tree view, the column view, the list view and the

thumbnail view.

If Names has been selected, all files can be uniquely identified since file versions do not have names

and a folder must not contain several files of the same name.

If the titles are displayed and a file has a released version, this version’s title (and not the title of the

possibly also existing draft version) is displayed. Only if there is no released version, the title of the

draft version is displayed, if such a version exists. If this title has not been set, the name is displayed.

7.3.13  Displaying or Hiding Files

If the folder hierarchy is widely branched, files in the hierarchy tree can be found easier when files of

irrelevant types are hidden. For this purpose, use the Display > File types submenu.
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Files of all types except folders and from version 6.5.0 also inactive files can be hidden. Folders cannot

be hidden since they constitute the file hierarchy.

7.3.14  Choose View

The menu item View > Choose View... opens a dialog in which you can specify the versions of the

content you want to be displayed in the Content Navigator. The selected view affects the folder

hierarchy (i.e. the titles displayed in it) as well as the preview, the details area, and the source code

view.

This menu item is not available if you use Infopark Rails Connector and your Rails application delivers

the preview pages.

7.3.15  Open New Window

This command opens a new browser window with the same view as the currently selected one.

7.3.16  Hoist Selection

For a better overview, each folder can temporarily be made the uppermost folder in the hierarchy. This

will cause the folder to be displayed at the very top of the view.

The Hoist Selection menu command does not change the base folder in the CMS. The currently

selected folder is merely displayed at the topmost position.

To achieve this, first select the folder to be displayed at the top. Then select the View > Hoist Selection

menu command.

Since the complete path of the currently selected file is displayed below the toolbar and each folder in

it is linked, you can easily switch to one of the folders in the path.

7.3.17  Refresh

If you have not issued a command in the Content Navigator for a longer period of time or worked with

several browser windows at the same time, the folder hierarchy might not be up-to-date since other

users might have made changes in the meantime. Since your browser is not automatically notified of

this, you should occasionally use the Refresh command from the View menu to update the display.

7.4  Workflow

With Infopark CMS Fiona, files can be edited, verified (signed), and released in so-called workflows. A

workflow can consist of several editing and verification steps. The last step in a workflow is the release.

Several user groups can participate in the editing and verification process. When a file is forwarded, it

is added to the task list of the next user group.

Files are not forwarded or committed automatically. These steps need to be made manually.

By means of the workflow actions Give and Take files can also be given to individual users or user

groups or taken over from a user not part of the workflow. These workflow actions interrupt the

workflow until the file is forwarded the next time or signed (in the verification phase).

http://www.infopark.com/1768163/12-Rails-Connector
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In order to perform a workflow step, select the corresponding menu command from the Edit >

Workflow submenu.

In the list view several files can be selected in order to perform the same workflow step with them

(even though the files are involved in different workflows).

If a workflow action cannot be performed for one or more files, a corresponding message will be

displayed.

7.4.1  Show Tasks

This menu command displays the list of your task. Tasks are files that have been assigned to you or

one of your user groups for editing, signing or releasing. The list also contains files that cannot be

forwarded or committed because they contain an error.

7.4.2  Finish Editing

This menu command opens a dialog, in which the list of files is displayed with which one of the

workflow steps Forward, Commit, Sign or Release can be performed.

7.4.3  Workflow Commands

Forward and Commit

After the draft version of a file has been edited, it should be forwarded to the next editing group or

committed for verification. If the workflow does not have a verification phase, the file can be released

only by one of its administrators or a system administrator after the last editing step.

A draft version can only be committed if it is complete. The version is complete if all its links are

resolved, i. e. if the target files exist. Furthermore, the values of all fields must be valid. Whether a

draft version is complete, is indicated in the overview to the right.

Sign

Workflows normally have a verification phase in which files are signed and released. Signing a file is

confirming that you approve of its content. You do not need to perform the Take action to be able to

sign a file.

The last step in the verification phase of a workflow is the release.

Release

Files need to be released before they can be published on the live server. In workflows including one

or more sign steps only the members of the last workflow group entitled to sign the file concerned

plus file administrators and superusers are permitted to release the file. In workflows without sign

steps the current editor of a file can release it in the last editing step.

Releasing a file turns its draft or committed version into a released version, making it available for

automatic publication by the system or manual publication by the system administrator.

A released version cannot be edited directly. However, you can create a draft version by means of the

Edit workflow action, provided that you have the write permission for the file concerned. This version

will be a copy of the released version.
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Reject

If you are a file’s editor or a member of a user group entitled to verify the file, you can reject its

released version instead of forwarding, signing, or releasing it. If a released version is rejected,

the file’s workflow begins again, i. e. the file appears in the task list of the first user group in the

workflow.

Revert

If a draft version is no longer needed and you do not want to release it, or if you would like to start

over with a fresh copy of the released version, use the Revert workflow action. You can then use the

Edit action to create a new draft version.

Unrelease

A file’s released version can be unreleased by the file administrator or a system administrator.

Afterwards, the file no longer has a released version. Thus, it will not be published.

If a released version is unreleased and the archiving function has been enabled by the administration,

the content will be archived. If the file does not have a draft version, a draft version will be created as

a copy of the previously released version.

Take

Perform this action, if you wish to edit a file (contained in your task list, for example). You will then

become the editor of the file.

If this file is being processed in a workflow, please perform the next workflow step after having

finished editing it. Usually, this is Forward or Commit. However, Sign or Release might also be

available.

Give

You can give a file to another employee or to a group not part of the file workflow. However, the

next editing group specified in the file’s workflow cannot be bypassed by this, i. e. the file needs to be

forwarded to the next group for the workflow to be continued. The recipient or the recipient group

can be specified on the Give page.

Enter here the login of the user or the name of the user group who or that, respectively, is to receive

the file. If you do not know the login or the name, click the selection button next to the input field

and select the desired name from the list of available names.

The selection button serves to complete a name contained in the input field. If you enter a name

partially and then click the selection button, only names containing the entered characters will appear

in the list. Empty the input field and click the selection button again to be offered the complete list of

names.

Click OK to confirm your selection. The file will then show up in the task list of the user or of the

members of the selected user group (see Tasks).

Edit

This workflow step creates a draft version of the file concerned. If the file has a released version, its

field values are taken over into the new draft version. By this workflow action you will become the

editor of the draft version.
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The workflow action Edit is performed implicitly when a field is edited (by clicking the field value in

the overview or details view or by clicking the editing button in the preview). „Implicit" means that

you do not need to select the workflow action Edit from the menu. It is performed automatically if a

draft version of the file does not yet exist.

If the draft version of a file is currently being edited by another user, the workflow action Take is

performed implicitly. However, you need to confirm this action since the data the current user has

entered might be lost.

If the file already has a draft version that you do not wish to keep, select the step Revert followed by

Edit.

You require the write or administration permission to be able to edit the draft version of a file.

As a superuser, i. e.as a user to whom the global administration permission has been given, you

automatically also have these file permissions.

Users who have the administration permission for a file or are a superuser are permitted to release

complete files at any time, independently of the workflow.

After a file has been edited it should be forwarded, committed or released.

7.4.4  Reminder Commands

Reminders...

This menu command shows an overview of your due reminders.

Define Reminder...

This menu command opens a new reminder dialog for the selected file(s). If there already are

reminders for these files they will be replaced.

Delete Reminder...

This menu command deletes reminders for the selected files. You will be prompted for confirmation.

7.5  History

In this menu you can find bookmarks pointing to the CMS files you recently selected. The most recently

selected file can be found at the topmost position in the list.

The history is saved in your personal preferences and is therefore available again in the next session.

7.6  Bookmarks

Bookmarks help you to quickly access often-used files. By means of the Bookmarks Menu you can select

a bookmark, add the selected file to your bookmark list as well as edit this list.

The bookmark editing page allows you to move bookmarks, to delete or rename them, and to create

new bookmark folders:
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You can rename a bookmark by changing its title in the input field above the list and clicking Apply

afterwards.

If you would like to create a new folder, first choose the desired bookmark folder by means of the

bookmark path in the upper part of the window, then select Create folder from the Edit menu. New

bookmark folders have a standard title that can be changed as described above.

In order to delete one or more bookmarks, first choose the desired bookmark folder by means of the

bookmark path in the upper part of the window. Then select the bookmarks to delete and choose

Delete from the Edit menu.

In order to move one or more bookmarks, select them and then choose Cut from the Edit menu. Now

select the target bookmark folder and paste the cut bookmarks into it.

7.7  Extras

7.7.1  Comment File

For each file, the CMS maintains a comment to which you can add instructions, descriptions, etc.,

provided you are permitted to modifiy the draft version of the respective file (i. e. have write access to

it).

A file’s comment is stored in the file’s log.

7.7.2  View Log

The Content Management Server logs most actions performed with files and versions. This helps to

reconstruct who changed which files and when this happened. The changes themselves, however, are

not recorded. The administrator has the possibility to anonymize the entries.

Only users who have read access to a file are permitted to read the log. A corresponding command can

be found in the Extras menu.

You can click the column headers to sort the entries by the data in the respective column.

The Content Manager adds to the log the file and version actions made plus a comment stating the

details, for example which field has been changed.
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7.7.3  Show Versions

This menu item displays the list of the archived versions of a file in a dialog. By clicking an archived

version, you can copy it to the draft version (provided the file concerned currently has no draft

version).

7.7.4  Check Layout

What a file or folder (i. e. its released version) looks like after it has been published can easily be

checked by means of the preview. However, if the layout files used for this don't work, they can be

checked by means of this menu command to find the errors.

When checking layouts, the draft and released versions are used in accordance with the selected view

that was chosen via the View > Choose view menu command.

The command for checking the layout can be found in the Extras menu. After the command has been

executed, the following page is displayed:

Here the errors are displayed that would occur when the content is published. If errors occurred, click

Show Details to find the offending places in the layout files or in the version concerned. Use the same

button, which is then labelled Show error messages only, to hide the details again.

Infopark CMS Fiona adds comments and error messages to the file that would be generated when the

version concerned is published. This file is then displayed so that unwanted output can be detected

easier than by looking at the layout code alone.

The administrator can provide different base layouts for the preview and the actual publication. This

means that the preview not necessarily shows the pages as they are published later on.

7.7.5  Unreachable Link Destinations

From version 6.5.0, using this menu item, you can have displayed in the corresponding dialog the list of

deactivated files and unreachable internal and external links.

7.7.6  System Administration

System Configuration

The system configuration includes file formats, fields, workflows, jobs, and channels. Elements of these

types can be changed by CMS administrators.

http://www.infopark.com/1194029/05-Layouts
http://www.infopark.com/1193317/04-RTC
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User Management

By means of the NPS user management users and groups can be created and permissions can be

granted to them.

7.7.7  Personal Preferences

By means of this menu command from the Extras menu, the current user can change several personal

settings in Infopark CMS Fiona according to his needs.

Change Password...

Using this menu command, which is available in the Extras > Personal Settings menu, you can change

in the corresponding dialog your own password for accessing the Content Navigator or the Content

Management Server.

Basic Settings...

The basic settings (accessible from the Extras > Personal Settings menu) include important general

settings such as the language used in the Content Navigator. These settings can be configured by

means of a dialog.

Local Applications...

This command can be reached via the Extras > Personal Settings menu. It opens a dialog with which

content in the CMS can be assigned the corresponding applications on the local PC so that the content

can be edited using the local application.

Content Navigator

By means of this menu item available in the Extras > Personal Settings menu several layout parameters

can be configured using the corresponding dialog.

Colors and Fonts

By means of the Extras > Personal Settings > Colors and Fonts menu item, the colors and fonts to be

used in the Content Navigator can be configured using the corresponding dialog.

7.7.8  User Interface

The Content Manager can be configured by a CMS administrator in order to adapt it to the individual

need of different groups of users. The available configurations can be found below the Extras > User

Interface menu command.

7.8  Help

By means of the items in this menu, the manuals and the About page can be opended.

Context help

This menu command displays a context-sensitive help page which can also be accessed via the icon

depicting a question mark.

http://www.infopark.com/1193031/03-Userman
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About Infopark CMS Fiona

This menu command displays information about Infopark CMS Fiona such as the version number.
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8
8  The Toolbar

Create document

This command creates a new file of the document type. Normally, HTML text is stored in

the main content of documents. However, different kinds of text can also be stored in

documents.

Links in documents are only managed by Infopark CMS Fiona if the documents have the text/

html MIME type. Typical file name extensions for this MIME type are htm, html, and shtml.

Create folder

This command creates a new file of the folder type. Folders can contain files. They also have

fields and a main content which makes them different from folders in a file system.

Links in folders are only managed by the CMS if the folders have the text/html MIME type.

Typical file name extensions for this MIME type are htm, html, and shtml.

Import file

This command imports a file from your computer’s file system into the CMS. The file can

either be stored as a new CMS file or replace the main content of an existing CMS file.

Up to version 6.0 the icon shown to the left is used for this function.

Finish editing...

This command displays the list of files for which a workflow command can be performed by

the current user. For each file the next step specified in the file’s workflow is offered. If the

workflow is in the editing phase and you are currently not the editor of the file, you will be

offered to take over the file if you are permitted to edit it and no other step is available to

you.

Tick the checkboxes next to the files for which you wish to perform the workflow step

offered and click OK.

Search

This button in the task bar starts a search for files whose name or title contains the text that

has been entered into the input field next to the button.
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To search for files containing the search words in a different field, use the search command

from the menu.

Copy

Copies the selected files to the CMS clipboard. Do not confuse the clipboard of the CMS with

your operating system's clipboard.

Cut

This copies the selected file or the files selected in the list view into the clipboard of the

CMS. If a file is inserted into the file hierarchy using Paste, it is removed from the original

folder, meaning that the file is moved. When a folder is moved, all the files contained in it

are moved as well. The links contained in the files moved as well as the links pointing from

other files to the moved ones are automatically adjusted.

Paste

This inserts the files contained in the clipboard of the CMS into the currently selected folder.

If the folder already contains a file of the same name as the one in the clipboard, the next

available counter is appended to the name of the file to be inserted (london becomes

london1, for example).

Deactivate (from version 6.5.0)

This deactivates the selected file or files selected in the list view, meaning that they are made

temporally invalid. After its release, the file will no longer be present on the live server.

Delete

This deletes the selected file or the files selected in the list view. The files are deleted

irrevocably after confirmation.

Up to version 6.0 the icon shown to the left is used for this function.

Tree view

Displays the file hierarchy as a tree.

Column view

Displays the file hierarchy in columns.

List view

Displays the contents of a folder in the file hierarchy as a list.

Thumbnails

Displays the contents of a folder in the file hierarchy as small images (thumbnails).

Details view (from version 6.5.0)

Displays the details of the currently selected file.

Preview

Displays the preview of the file selected in the Content Navigator. By means of editing

elements you can modify the parts of the file to which you have write access.
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Separate Preview

Displays the preview of the selected file in a separate browser window. No editing elements

are offered in this view.

Choose view...

Specifies whether the draft versions or the released versions of the files are displayed.

Help

Opens the online help.

Log out from Infopark CMS Fiona

This menu command ends your CMS session.

Please log out of the Content Manager when you leave your workplace. Otherwise

unauthorized users have access to the system and can change data in your name.

By default, you will be automatically logged out for security reasons if you have not used the

system for two hours (this time can be configured by the administrator).

Show edit markers (from version 6.6.0)

In the preview, this button enables edit markers if they are hidden and vice versa. The

corresponding option can be found in the Choose view dialog.
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9
9  Dialogs

9.1  Tasks

You can open your task list using the Workflow > Tasks menu command. Tasks are files assigned to you

or one of your user groups for editing, signing or releasing:

In the list the task type (edit or sign), the file path, the title of the version, the user or user group

responsible, and the file comment are shown. You can use these pieces of information to determine

the importance of the individual tasks.

You can sort the tasklist by the criteria given in the list header. For this, click the desired sort criterion.

The criterion by which the list is currently sorted and the sorting direction are indicated by a small

arrow.

After opening the task list, your personal tasks are displayed. By selecting All tasks from the drop-

down menu the tasks assigned to you indirectly via your group memberships are displayed in the list as

well.

Click a file in the list to select it in the Content Navigator. You can then edit it there or perform the

required workflow step. The task list window remains open in the meantime, so that you can return to

it after the task has been completed. Click Refresh to remove the completed tasks from the list and to

have new ones listed.
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9.2  Finish Editing

This dialog page can be opened using the Workflow > Finish editing menu command. It displays

a list of the files with which one of the workflow actions forward, commit, sign or release can be

performed:

You can sort the list by the criteria given in the list header. For this, click the desired sort criterion. The

criterion by which the list is currently sorted and the sorting direction are indicated by a small arrow.

For each file the next step specified in the file’s workflow is offered. If the workflow is in the editing

phase and you are currently not the editor of the file, you will be offered to take over the file if you

are permitted to edit it and no other step is available to you.

Tick the checkboxes next to the files for which you wish to perform the workflow step offered and

click OK.

In contrast to the task list, the list in this dialog does not contain incomplete files, i. e. files containing

unresolved links, for example.

9.3  Edit Links

There are different kinds of links that are described in section Link Management. Using this dialog, you

can edit links contained in the main content or in HTML fields of a draft version:

Links can have a title which is displayed as a tooltip by most browsers.

The target of a link can be internal or external. Internal links point to a file in the folder hierarchy of

Infopark CMS Fiona. Example:
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/intranet/de/press.html

External links are URLs pointing to any target outside the CMS. Fiona recognizes them by the protocol

identifier (http:, ftp:, mailto:, etc.). External paths, i. e. paths whose target is not a CMS file must

be prefixed with external:. Examples:

ftp://ftp.infopark.com/path/to/file.html

external:/path/to/file.html

An anchor is a position in a file at which the browser is to diplay the file. Links to images do not have

anchors. The frame is the name of a browser window in which the link target is to be displayed. Select

New Window, if the link target should always be displayed in a new window.

You can select the path of the link target by means of a new Content Navigator window by clicking

the selection button. With internal links you can now navigate the folder hierarchy and change the

display mode (from tree to column view, for example) or import a file. With external HTTP and HTTPS

links you can navigate on the correspondig page. Use the History or Bookmarks menu to switch to a

page you have visited or defined before.

If the link target is a file, you can specify its path using a new Content Navigator window, by clicking

the selection button. Here choose the desired file. If you wish, change the display mode (from tree to

column view, for example) or import a file.

Finally, click OK to return to the previous page. Click OK there too after you have finished entering the

link data.

Only free links can be deleted directly via the link editing dialog. Links contained in the main content

or in an HTML field of a draft version need to be removed manually.

9.3.1  Using URL Parameters

External URLs may point to CGI scripts (CGI, PHP). Three ways for passing parameters to the scripts

exist:

• Passing parameters as pathinfo:

Parameters are appended to the script's URL seperated by "/" characters. Example:

http://www.somewhere.de/cgi-bin/search/Content-Management/infopark

• Passing parameters using the HTTP method GET:

Parameters are appended to the script's URL after a "?" character. Two parameters are separated

by an "&" character (ampersand). Values without a name or name/value pairs may be appended to

the URL. A value is separated from a name using a "=" character. Example:

http://www.somewhere.de/cgi-bin/search?keyword=NPS&casesensitive

• Passing parameters using the HTTP method POST:

The parameters are passed via an individual document which the browser generates automatically

as it sends form data to the script's URL. Normally, this way of parameter transfer is invisible to the

user. The CMS manages this kind of URLs as external URLs.

The following special cases need to be observed when using URLs of this kind:

• According to the HTTP specification, URLs must not contains spaces. If you want to use spaces,

replace them with "+" characters.
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• URLs must not contain special characters. Special characters need to be encoded as %HH, where HH

represents two hexadecimal digits. These digits describe the character's position in the character set

used (normally iso-latin-1 or iso-5899-1). Examples:

" " (space) = %20

% (percent) = %25

& (ampersand) = %26

• If several parameters are given using the method GET, the CMS will save them in the link URL in

alphabetical order.

9.4  Edit Link Lists

Link lists are fields that can contain several so-called free links. By means of free links you can create

link collections, for example. From version 6.7.0 the number of links to be contained in a link list can be

set in advance.

The dialog page for editing link lists contains the same fields as the page for editing individual links so

that new links can be inserted into the link list. Furthermore the individual links contained in the list

can be edited.

In order to modify the parameters of a link in the list, click the corresponding line. The input fields in

the upper area of the page are now filled-in with the parameters. Change the data as desired and click

the Apply button to take them over into the list.

To delete links from the link list, tick their checkboxes and click Delete marked below the list.

To sort the links contained in the list, click the Sort button. This function is available from version 6.6.1.

http://www.infopark.com/1193681/02-Edit
http://www.infopark.com/1193681/02-Edit
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9.5  Edit Fields

Using this dialog, version fields can be edited. For a better overview and easier editing, CMS

administrators assign version fields to so-called field groups. For each file format, individual field

groups can be created. This is why there is no unique dialog for editing fields. Here is an example:

Depending on the field type, different input fields exist with which the field value can be specified:

• Character strings such as the title of a version can be entered directly.

• HTML values can be edited in a simple text input field or using one of the available editors, the

integrated HTML Editor, the Microsoft HTML Editor, or a local applications.

• Date fields can be filled-in manually or using the date selection dialog.

• The value of a selection field can be specified by means of a drop-down menu.

• With multiple selection fields the individual values can be selected using checkboxes or a multi-

selection list.

• Links are defined using several input fields.

For some fields such as the file format, Infopark CMS Fiona offers a completion function (identifiable

by a button with a green check):

Enter into the input field a part of the name or title of the value to search for or leave the input field

empty. If you then click the green check button, your input will be completed immediately, provided

that only one value matches your input. If several values exist, they are offered to you for selection in a

list. Click the desired value to have it placed into the input field, then confirm your selection by clicking

OK.

9.6  Edit Field

Individual file or version fields can be edited on different dialog pages, depending on the field type.

See the overview.
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9.7  File Selection

Using this dialog page, files can be selected as link targets, for example.

Here, the important file functions of normal Content Navigator windows are available so that you can

create or import or search for files, for example.

Select the desired file, then click OK.

9.8  Select Workflow Step

For a user to be able to edit a version, he needs to become the editor of the version first. For this it is

required to perform a workflow step:

• Take for draft versions,

• For released versions one of the steps revert and edit.

In your personal preferences you can specify that Infopark CMS Fiona should perform workflow steps

without asking the user for confirmation. This setting does not apply to the workflow step take

because it should be considered that the current editor of a file’s draft version is not notified when

someone takes the version and thus might lose his work.

From version 6.5.0: If you have activated the confirmation of workflow steps in your personal

preferences, the step can additionally be commented. This text then appears in the task list of the user

or user group responsible for the next step.

9.9  Assign File Access Permissions

This dialog can be reached via the Administration tab of the details view. Use it to specify which user

groups should have a specific permission for the currently selected file.
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In order to grant a user group the permission specified in the dialog enter the name or a part of it into

the Group input field and click the search button (magnifying glass). You can also leave the input field

empty.

Group selection

When selecting a user group, if more than one user group match the characters entered into the input

field, these groups will be listed in a selection dialog. If the input field was empty, all groups that can

be selected (and have not been assigned yet) are listed:

Select the groups you would like to grant the permission concerned and return to the assignment

dialog by clicking OK . To revoke the permission concerned from one or more groups, select them in

the group list and click Remove . Click OK to grant the listed groups the permission concerned.

9.10  Date Selection

When a field value of the date type is being edited or a date is entered as a search criterion, this date

can be manually entered into the input field or by means of a date selection dialog.
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In the date selection dialog, choose the month and the year by means of the drop-down lists, click the

desired day of the month and adjust the time as desired.

9.11  Color Selection

This dialog can be opened from the Colors and Fonts page, to specify colors more accurately, for

example for the background:

Clicking a color does not close the dialog page. For this, click the OK or Cancel button.

9.12  Choose File Format (Extended)

Every file is based on a file format. The format determines, among other things, the type of the file

and its version fields. File formats are created by administrators.

The dialog for selecting a file format is displayed

• when you create a new file and more than one format exists for this new file. The formats

available depend on the type of the file as well as, optionally, on the format of the folder in which

the file is created.
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• when you change the format by means of the properties overview or the details view.

In the dialog, the titles of the available formats are listed. If only a small number of file formats is

available or has been recently used, the dialog has no field into which the name of the desired format

can be entered and optionally completed using the check button to the right of it. If only one format is

available, only its title is displayed.

When the mouse cursor hovers over a file format, its name is displayed as a tooltip. If the number of

available formats does not fit into the dialog, only recently used formats are offered for selection. For

having displayed more formats, enter a part of the format name you are looking for into the input

field (or clear the input field) and click the button on the right-hand side of it. You can now select the

desired format by clicking the corresponding entry in the list:

Finally, click OK to confirm your decision.

9.13  Unreachable Link Destinations

From version 6.5.0 Infopark CMS Fiona offers a possibility to automatically check link destinations. This

checking detects external Links pointing to web pages currently not available, internal links to inactive

CMS files, and internal links whose destination does not exist. The corresponding dialog page can be

accessed via the Extras menu.



Dialogs

Editing Content – © 2011 Infopark AG 55/101

The CMS checks links in the background. The current status of this process is displayed in the upper

section of the dialog. Underneath, the list of unreachable link destinations is located.

To start checking the links, click the Start checking button. Fiona now tests the availability of all the

links contained in the released and draft versions of files you are permitted to modify or whose editor

you are. During this process, the button "Stop checking" is displayed instead of "Start checking". Click

this button to stop this process.

Checking a large number of external link destinations may take some time. Click the Refresh button to

update the status display.

In detail, the following information is displayed in the Status section.

• Check: Running or Stopped.

• Last started at: Specifies the point in time the link destinations were last checked for availability.

• Checked: Specifies the percentage of link destinations checked so far.

• External link destinations (total): Specifies the total number of external link destinations. If several

links have the same destination, the destination is counted only once.

• Unreachable: Specifies the total number of external link destinations that cannot be reached.

• Inactive files with referrers: Specifies the number of CMS files that are inactive and have links

pointing to them.

After checking, in the list below the status section the following information about the links found is

displayed:

• Link destinations that are inactive or are not exported for some other reason.

• Unavailable external link destinations as far as they are prefixed with http: oder https:.

The type of a link can be determined from the icon shown in front of each entry in the list. External

links are marked with a globe icon, internal links with the corresponding symbol for the file type.

If required, click an entry in the list to replace the destination in the corresponding links with a

different link destination.
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Administrators have the possibility to exclude particular links from the checking process. This can be

recommended if required links (that must not be deleted or modified) are often not available and it

becomes difficult to find the relevant links in the list.

If the list contains an unusual large number of unavailable external link destinations, and if the

corresponding URLs can be opened in the browser, please ask an administrator to check the network

settings.

9.14  Choose New Link Destination

This dialog, which is available from version 6.5.0, can be reached after clicking a link destination in the

Unreachable Link Destinations dialog which is accessible via the Extras menu.

You can use this dialog to change all the links pointing to a file. In the upper area of the dialog you

can find information about the link destination. The list below contains the CMS files in which one or

more links point to the file concerned. Only files you are permitted to modify are listed. You can click a

file in the list to select it in the Content Navigator and make changes to it if required.

In the upper part of the dialog, you can specify a new link destination for all the links that are

contained in the files listed and that have the destination concerned. If the links point to an inactive

file in the CMS (and not to an external destination), their common destination can also be specified

using the file selection dialog by clicking the corresponding button. In the Content Navigator window

which is then opened, you can navigate as usual, use bookmarks, or choose a different view. Confirm

your file selection in the Content Navigator window by clicking its OK button. This causes the path of

the selected file to be placed into the input field.

Then click Apply to store the new destination in the links of the corresponding files.

When link destinations are replaced, the following rules apply:

• The link destinations are stored in links of draft versions whose editor you are. If the corresponding

file also has a released version and if this version also contains links to the same unreachable

destination, the destinations of these links are not corrected.

• If the corresponding file only has a released version, it is copied to a draft version in which the

corresponding links are provided with the new link destination. For the draft versions a new

workflow is started in which you are made the current editor.

• Links in committed versions are not corrected.

http://www.infopark.com/1214180/01-content
http://www.infopark.com/1410505/11-Linkchecker
http://www.infopark.com/1410505/11-Linkchecker
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Please note that the files whose draft versions you have modified need to be released for the changes

to take effect.

9.15  Versions

In addition to logging (see View Log), the Content Management Server supports versioning. If the

administrator has enabled this function, the Content Management Server archives all released versions

as soon as they are unreleased or replaced by another release of the file concerned. The archived

released versions document the published content of the file.

You can have the versions of the currently selected file displayed by means of the corresponding

command in the Extras menu.

If the corresponding file currently has no draft version but archived versions, you can select one of

them to use it again. To do this, click the respective entry in the list. A copy of the selected archived

version will be provided as the draft version, and a workflow will be started (if a workflow is assigned

to the file). If all the links are still intact and the draft version is complete in every other respect, it can

be released again immediately.

If an archived version cannot be clicked although the respective file does not have a draft version, you

do not have the permission to edit the file. In this case, please contact the CMS administrator.

If the file in question currently has a draft version, revert it first using the corresponding workflow

command from the Edit menu. Afterwards, reopen the version list and select the archived version to be

copied to the draft version.

9.16  Define Reminder

Using this dialog, which can be accessed via the Workflow menu, you can define a new reminder for

the file currently selected in the Content Navigator or edit the existing reminder of the file.
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Every reminder is associated with one or more recipients. By means of the corresponding input field

you can specify or select the users or the groups for which the reminder is created and add them to the

recipient list.

To define the date of the reminder, select from the drop-down menu a period relative to the current

date or enter a specific date. A specific date can also be selected by means of the calendar.

If the administrator has enabled the e-mail notification for reminders, the recipients will receive e-mail

notifications at regular intervals (defined by the administrator). Each time the e-mail notifications are

sent, each recipient will receive at most one e-mail informing him about the files that are due. If the

recipient list contains user groups, the CMS automatically determines their members.

If required, enter in the comment field an informative text describing the task or indicating its

urgency.

9.17  List Reminders

Using this dialog, you can have all your reminders displayed. Furthermore, you can search for

reminders that match particular criteria. You can select the function you wish to use from the drop-

down menu in the upper area of the dialog.

9.18  My Due Reminders

http://www.infopark.com/1480130/13-Reminders
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The dialog shows all due reminders of the current user. A reminder is considered due if its due date has

been reached. In the list, for each file additional information such as the recipients, the due date, and

the comment is given.

Click an entry in the list to navigate to the corresponding file in the Content Navigator.

The Edit and Delete buttons refer to all the reminders that are checked.

9.19  Search

The list of reminders present in the CMS can be filtered using the following criteria:

• a receiver,

• a range of due dates,

• a subtree in the folder hierarchy

The default criteria are the current user and due dates in the past.

Click the Search botton to run the search with the specified criteria.

9.20  Creating a New File

By means of this Dialog you can create a new file. If more than one file format is available for the file,

you can select the desired one from the list below the input field for the name. This is shown in the

following screenshot for a folder:

If the number of available file formats is very large, you are offered extended possibilities for selecting

the file format.
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9.21  Choose View

This dialog as well as the menu item and the toolbar button with which it can be opened are not

available if Infopark Rails Connector is used and the preview of your Rails application has been

integrated into the Content Navigator. In this case the draft versions of the CMS files are displayed in

the preview. If a file does not have a draft version, the released version is used.

Used Versions

You can choose one of three combinations of the versions used for the preview and other views in the

Content Navigator:

• Draft versions (6.0.x: Layout): The draft versions of content and layout are preferred. If required,

i.e. if no draft version is available, the system uses the released version instead.

• Draft versions (Editorial) (6.0.x: Editing): For displaying content, the draft versions are preferred.

If a file only has a released version, this version is used. With layouts, the system behaves as in the

Released versions mode.

• Released versions (6.0.x: Live Server): In this mode, only the released versions of the content and

the layouts are used. With files that do not have a released version, the draft versions are not used

as a replacement. Instead, the files are treated as if they were missing (which is, in fact, the case on

the live server if no released version exists).

Drafts will cause released versions to be used as a replacement, if required. The reverse, however, is

not the case.

The view modes affect the folder hierarchy (the titles displayed in it), the preview, the details view,

and the source code view.

Layout Set

For the preview a set of layout files (in short layout set ) is used. A layout set consists of a certain

amount of layout files of the same name. These files are located in different folders (by definition,

since names must be unique in folders). For previewing files in a folder, the CMS uses the layout file of

this name located in the folder concerned. If the layout file is not present, the CMS searches for it in

the folder on the hierarchy level above the current one (i. e. in the parent folder). This is repeated until

the layout file has been found. If even the base folder does not contain a layout file of the layout set’s

name, the name of the missing layout file is displayed instead.

http://www.infopark.com/1768163/12-Rails-Connector
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Layouts can include other layout files of any name. If such an included layout is missing, a

corresponding message is displayed.

Displaying Edit Markers

This option is available from version 6.5. It determines whether editing elements are displayed in the

preview or not. Using editing elements, you can directly edit content (to which you have write access)

in the preview, i.e. without having to switch to a different view.

From version 6.5, administrators can add editing elements to the preview.

Apply to all new windows and save as my personal preference

The effect of this setting is that your choices are stored in your personal preferences and are

immediately applied to the the current and all future windows. Otherwise, only the current window is

affected.

9.22  Content Navigator Settings

By means of this dialog that can be accessed via the Extras > Personal Settings > Content Navigator

menu item several layout parameters can be configured. Use Reset to Default to restore the original

settings provided by the administrator.

View

This option is used to specify the preferred view in the Content Navigator window, for example the

tree view or the column view. For further information about these views see section Hierarchy Display.

Display narrow columns in the column view

This option specifies whether columns should be narrower as normal in the column view. If this option

is selected, more columns can be displayed. However, long text lines in the columns (such als long file

names) might be wrapped.

Show toolbar

Here the toolbar can be disabled to save space. All the functions can also be accessed via the menu.

Show menu

http://www.infopark.com/1339941/15-npsgui
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Specify here whether you wish the menu to be shown or hidden by default. You can show or hide it

any time by clicking the divider between the menu area and the main area of the window.

Releative dates

Specify here whether you wish dates to be relative (example: active since February 2011) or absolute

(active since 02 / 01 / 2011 15:36).

Display width

You can furthermore determine in this dialog the width of the selected view in relation to the details

overview to the right. Use the scroll bars for this (click the target position).

9.23  Colors and Fonts

On this page, which is accessible via the Extras > Personal Settings menu, the colors and fonts to be

used in the Content Navigator can be configured:

Click Apply theme intermediately to apply all of the theme’s settings to this page without closing it.

You can then select colors different from the theme’s respective colors, if you wish.

Click Reset to Default to restore the original settings provided by the administrator.

Theme

Infopark CMS Fiona includes several themes that differ with respect to the colors and icons used.

Select the desired theme from the drop-down list. If you click Apply theme, all of the theme’s settings

are immediately applied to the configuration page. Click OK, to apply the theme to the Content

Navigator.

Font

Here you can select the font and font size to be used in the Content Navigator.

Source code font

Here you can select the font and font size to be used for source code displayed in the Content

Navigator.

Color Settings
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By means of the other options on this page you can chose the colors to be used for individual elements

of the user interface. Click the colored box next to the desired element description, for example

background color, to open the color selection page. Here, click on the desired color (see Color

Selection). Click OK to use the selected color.

Please note that the individual color settings override a theme’s corresponding colors. Therefore, it is

required to click Apply theme to undo the changes made to individual colors.

9.24  Basic Settings...

The basic settings (accessible from the Extras > Personal Settings menu) include important general

settings such as the language used in the Content Navigator. Click Reset to default to restore the

original settings provided by the administrator.

Start area

The Content Navigator’s area in which you wish to begin working after logging in, the start area, can

be specified by selecting it from the Start area drop-down menu. The areas listed here depend on your

user permissions.

Select Wizard Selection as start page if you prefer to work with wizards and wizards have been set up

by the administrator.

Main folder

The main folder is the folder to appear at the topmost position (in place of the base folder) in the

folder hierarchy after logging in. If you often only work with files contained in one folder, enter it

here or select it using the selection dialog.

Language

Select the language to be used in the user interface of the Content Manager.

Confirm workflow actions

After selecting workflow actions such as forward, commit, or release, you are normally asked to

confirm that the action is to be performed. This behavior can be switched off by deactivating this

option. Please note that for the give workflow action the confirmation dialog is nevertheless displayed

since the recipient of the file must be specified in this case.
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Send report as e-mail

Here you can specify whether you wish to be notified via e-mail about due reminders. This only applies

to reminders to whose recipient list your login or one of your groups has been added.

The following prerequisites for receiving e-mail notifications exist:

• E-mail notification must have been configured properly by the administrator.

• Your e-mail address must have been stored in the user management.

9.25  Local Applications...

This command can be reached via the Extras > Personal Settings menu. It opens a dialog with which

content in the CMS can be assigned the corresponding applications on the local PC so that the content

can be edited using the appropriate local application.

Prerequisites

Draft versions can be edited using a local application if this has been determined by the system

administrator in the format of the file concerned. The file is opened locally by means of a Java applet.

This means that using Java applets must be permitted, and Java must have been enabled in your

browser. If these prerequisites are met, the corresponding application can be executed on your

computer by means of Java. You do not need to manually download and open the file.

After finishing your work with the local application, click OK on the Java applet page to upload the

file to the CMS.

Using this Dialog

Using this menu command, you can specify for each file name extension the path of the application

to be used. If you want to pass commandline arguments to the application, please use the following

format:

xterm -title "Editor Window" -bg pink -fg black -e vi

Use double quotation marks to prevent single arguments containing spaces from being interpreted as

several arguments.

http://www.infopark.com/1480130/13-Reminders
http://www.infopark.com/1193052/01-Users
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In the bottom area of the dialog you can also specify which character set folder, document, or layout

files are to have when they are edited. This is useful for editing them with local applications that do

not support UTF-8. The file will be converted back to UTF-8 when it is imported into the CMS after

editing.

Click Reset to Default to restore the original external editors settings provided by the administrator.

9.26  Change Password...

Using this menu command, which is available in the Extras > Personal Settings menu, you can change

in the following dialog your own password for accessing the Content Navigator or the Content

Management Server.

First enter your current password into the Old password field. Then enter your new password and

repeat it in the corresponding input fields.

Upper and lower case matters with passwords. All input is hidden and cannot be checked on-screen.

Confirm your password change by clicking OK. You can cancel this process at any time if you wish

It is not necessary to log in again to the Content Management Server after changing the password.

9.27  Confirming an Action

By means of this dialog the CMS asks you to confirm a particular action such as deleting a file:

Click OK to perform the action concerned or Cancel to not perform it.

9.28  Editing Content Using a Local Application

In your personal preferences you can define local applications for editing the main contents of the

draft version if the format of the file concerned permits this. Having configured a local application for

a file name extension such as .html, you can use the Edit main content with... command in the Edit

menu and specify Local application as the editor to use.
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This causes a Java applet to start (on your local computer) the program associated with the file name

extension:

The applet saves the content to be edited in a temporary file and passes the path of this file to the

local application. After you have saved your changes and finished editing the file, click OK in the

applet to save the content in the draft version of the CMS file concerned. This will close the applet.

With Fiona 6.6.1 and later, the content being edited can be saved to the draft version using the Save

button so that you can preview your changes without having to close the applet.

Please note that saving always requires two steps. At first, the content needs to be saved using the

local application. Then it must be written to the CMS using the applet.

9.29  Sorting Links

From version 6.6.1 of Infopark CMS Fiona, the links contained in a link list can be sorted manually. To

do this, proceed as follows:

1. Edit the link list by clicking the corresponding field in the Content Navigator, for example on the

References tab in the details view:

2. In the link editing dialog, click the Sort button:
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3. Now move the links individually to the desired position using the mouse:

Finally, click OK to return to the link editing dialog.

9.30  Importing a File

This dialog shows up if you select the Import file command from the File menu. It allows you to

import a file from the file system into Infopark CMS Fiona. Please note that files cannot be imported as

documents and folders if they contain characters not permitted in XML documents.

There are two ways of importing a file:

• A new file is created in the CMS. the contents of the file to import is stored in the draft version of

the new file. If a folder has been selected in the hierarchy, the file will be created in this folder and
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not on the same hierarchy level as the folder itself. If no folder is selected, the file is created on the

same level as the selected file.

• The main contents of the draft version of the file currently selected in hierarchy is replaced by the

contents of the file to be imported.

Select the file to be uploaded (using the Browse button, if necessary) and click Import. If only one file

format is available for the type of the file to be imported, the file is imported immediately. Otherwise,

a dialog is displayed, allowing you to choose the file format to be used.

In order to make an office file (a Word document, for example) available as HTML content, import it as

a resource first. Then convert it to HTML using the corresponding command from the File menu.

The formats that can be chosen when importing a file depend on:

• the name extension of the file to import

• the formats the folder in which a new file is to be created permits.

This is an example for creating a new file while importing:

• The name extension of the file to import is compatible with the formats A, B, and C.

• The file is to be imported into the folder X.

• The format of the folder X determines, that X may only contain files with the formats A, C, and E.

• The formats remaining applicable are A and C.

9.30.1  Special Import Features with HTML Files

When importing HTML files, the content of the body element becomes the main content of the CMS

file. If the file to be imported contains a head element, the title of the CMS file will be extracted from

it (title element). If the head element contains meta elements, the CMS attempts to assign their

values to the corresponding fields of the CMS file provided that the format of the CMS file includes

fields with the same names. No error message is output if this is not possible. Example:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/

html4/loose.dtd">

<html>

<head>

<title>The title of the file</title>

<meta http-equiv="content-type" content="text/html; charset=UTF-8">

<meta name="abstract" content="The abstract">

<meta name="short_title" content="The short title">

</head>

<body>

This is the main content

</body>

</html>

9.31  Search

In the Content Navigator’s toolbar an input field can be found, into which a search word or phrase

can be entered. After doing this, hit the return key or click the mgnifying glass icon to have the search

performed. All file names and version titles will be searched. The results will be displayed in a list on

the search page.

This search page is also opened when the Search command is chosen from the search menu:
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Each line in the upper area serves to specify a search criterion. Using the drop-down menus to the left,

you can specify the fields the CMS should investigate.

Using the second popup-menu the search can be restricted. The options available here depend on

the field type. With character strings, for example, you can restrict your search to field values that

begin with, contain, or are equal to the search term. With date fields, a predefined period of time or a

particular date can be specified.

The last element of a search criterion is the search term. In most cases the search term is a character

string. It might, however, also be a date (see Date selection). With fields of the type selection and

multiple selection the search terms are predefined (they correspond to the selectable field values) and

can be specified using a drop-down menu or checkboxes.

The symbols to the right-hand side of a search criterion have the following function:

Add and remove search criteria

A another search criterion on a new line. The line is placed below the line whose plus
symbol was clicked. By default, the field of the new criterion is set to the one that succeeds
the field in the line above.

Removes the search criteria concerned.

If more than one search criterion has been specified they are combined using and. This means that the

search result will include only files that meet all criteria.

After the search has been performed using the Search button, the files found will be listed in the result

list. To change the sort direction from ascending to descending and vice versa, click the Name column

header.

If you click an entry in the result list, the corresponding file in the Navigator is selected. The search

page remains open, allowing you to work as desired with the listed files.

In order to delete one or more files or to perform a workflow step, mark the check boxes of the files

concerned and select the desired command from menu.
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9.32  Wizards

The menu of the Content Navigator includes several wizards that are part of Infopark CMS Fiona. For

information about other wizards, please contact your CMS administrator.

9.32.1  Import Archive

By means of this wizard you can import the contents of an archive into the CMS. During this process,

the files contained in the archive are created as CMS files, oberserving the folder structure in the

archive.

As the files in the archive are imported, the file access permissions and the presets for using file

formats are taken into account. This means that the wizard imports files from the archive only if

• you are permitted to create files in the folder concerned,

• for each file at least one appropriate file format exists that may be used in the target folder,

• and, if applicable, you have been granted the global permission required to use this file format.

To import an archive

• select from the File menu the corresponding command,

• determine the archive to be imported by clicking the Browse button,

• and specify the target of the archive. You can unpack the archive into the folder currently selected

or into a new folder which will be given the name of the archive.

Click OK to finally import the archive. If more than one file format is available for individual files

contained in the archive, you will be asked to select the one you whish to use.

9.32.2  Edit Image

The image editing wizard makes it possible to perform standard image operations inside the CMS, i.e.

without having to use applications installed locally on the client computers.

To edit an image, first select it in the Content Navigator, then call the Edit image... command from the

Edit menu.

You can now select one of the three available categories Scale, Rotate / flip or filter and click OK, to

apply an operation from this category. In total, the following operations are available:
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• Scale

• 100 px changes the image size so that the longer side is 100 pixels high or wide, respectively. The

aspect ratio is kept.

• 200 px changes the image size so that the longer side is 200 pixels high or wide, respectively. The

aspect ratio is kept.

• x % makes it possible to change the width and the height by the percentage specified .

• Height x px changes the image so that its heigth is the number of pixels specified. The aspect

ratio is kept.

• Width x px changes the image so that its width is the number of pixels specified. The aspect ratio

is kept.

• Rotate / mirror

• Rotate CW by 90° rotates the image clockwise by 90°.

• Rotate CCW by 90° rotates the image counter-clockwise by 90°.

• Rotate by 180° rotates the image by 180°.

• Flip horizontally flips the image in the vertical axis at the image center.

• Flip vertically flips the image in the horizontal axis at the image center.

• Filter

• Sharpen

• Blur

• Convert to grayscale

• More contrast

• Less contrast

• Negative

• Monochrome

After performing an image editing operation, (here More Contrast), the result is displayed next to the

original image:

By means of the available buttons the following can be achieved:

• Back reverts the image and returns to the operation selection dialog. From there, you can also

jump back to the category selection window by clicking Back once more.
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• Next stores the displayed result in the draft version of the image file and returns to the category

selection dialog so that you can continue to edit the image. It is now no longer possible to undo

the last operation.

• OK stores the result in the draft version of the image file and exits the wizard.

• Cancel exits the wizard without storing the result of the last operation in the draft version of the

image file.

9.32.3  Find Differences Between Versions

You can open this dialog, Determine changes between versions, by means of the Compare versions...

menu item from the Extras menu. It allows you to compare two versions of the selected file with each

other in order to determine the differences between these versions:

In the upper section of the dialog you can select the base version (normally the original, older version)

and the target version (mostly a more recent version such as the draft version). If the file concerned has

a large number of versions, a drop-down menu is displayed instead of radio buttons.

In the lower section you can select the fields that are to be compared with each other. If the file has

many fields, a multiple-selection list is displayed instead of check boxes.

After having selected the versions and the fields to be compared, please click Next to perform the

comparison. On the results page, the changes are displayed for each field using font styles. Red, struck-

through text no longer exists in the target version, green text in italics has been added to the target

version:

Click Back to compare other versions or fields with each other, or Close to terminate the wizard.

Configuration note
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Administrators can configure the wizard in the diff section of the wizards.xml configuration file

located in the config directory of the CMS instance concerned.
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10
10  Overview of the Standard Fields

10.1  File Fields

Every file has the following built-in file fields, independently of its type. No additional file fields can be

defined, however, you may define any number of version fields.

File field Value

ID
(id)

The ID of the file is assigned by the Content Manager when the file is
created. It is unique and never changes. IDs are not reassigned when they
are no longer needed.

Is Content Service File
(isContent-
ServiceObject)

This field specifies whether the file originates from a Content Service. In
this case it cannot be modified. Content Service files serve to synchronize
content and layout in multiple CMS instances.

Last Content Service
(lastContent-
Service)

The date on which the file was last updated or created by a Content
Service.

Name
(name)

The file’s name. You can rename the file if you are a CMS administrator or
the file administrator.

Path
(path)

The path of a file defines its position in the folder hierarchy. It is displayed
in the CMS Navigator below the toolbar. It cannot be edited. It changes
when the file is moved.

File type
(objType)

The type of a file determines its purpose. The file type is set when a file is
created and cannot be changed subsequently.

File format
(objClass)

The format on which a file is based defines most properties of the file
and its versions, for example the file type and the additional fields. The
format of a file can be changed only by the file’s administrator or by a CMS
administrator.

Revision
(version)

The revision number is increased by one on each release.

Workflow
(workflow)

A file’s workflow determines the editing and signing steps it has to go
through for its release. The workflow of a file can be changed only by the
file’s administrator or by a CMS administrator.

Ignore on export
(suppressExport)

The value of this file field determines whether the file is exported or not. It
can be modified only by the file’s administrator or by a CMS administrator.
Even if a file is not exported the file and version fields it contains can be
read out when other files are exported.
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The complete list of file fields can be found in the Tcl reference manual.

10.2  Version Fields

There are predefined as well as additional (custom) version fields. In the following overview the most

important predefined version fields are listed:

Predefined
version fields 

Value

Titel
(title )

When a file is published, the title of the released version of the file
normally becomes the title of the web page. As opposed to a file’s name,
the title of a version need not be unique. Please note that the length of a
title must not exceed 250 characters, all character conversions included (to
UTF-8, for example).

Main content
(body)

The main content of files of the document and folder type normally
contains HTML text. The main content of files of the image and resource
type contains the binary data. The main content of templates is the
template code.

File name extension
(contentType)

The file name extension is used when a CMS file is published. Layouts do
not have this field because they are never published.

Editor
(editor)

The login name of the user who currently edits the draft version.

Channels
(channels)

The channels to which the version is assigned (can be used in conjunction
with the Portal Manager).

Last change
(lastChanged)

Date of the last change to the file’s released version.

Valid from
(validFrom)

Date from which the version is considered during the export (the default
value is the creation date, 0 hours). Layouts do not have this field.

Valid until
(validUntil)

Date from which the version is no longer considered during the export
and the links to it should be ignored. If the value is not empty, it must be
greater than validFrom. Layouts do not have this field.

The complete list of version fields can be found in the Tcl reference manual.

http://www.infopark.com/1209610/01-params
http://www.infopark.com/1208578/01-params
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11
11  Web Folders

In Microsoft Windows, there is a folder named Web Folders. This folder is either present from the

beginning or can be added by installing the Internet Explorer, version 6 or higher. This folder can

have subfolders, the so called web folders. When you create a web folder you assign it a URL which

points to a WebDAV service on the network. With this URL Windows can, for example, determine the

contents of this folder.

Infopark CMS Fiona provides such a service so that you can access the files stored in the Content

Management Server as if they were files in your file system. Apart from a few system-dependent

restrictions, you can handle these files just as you would handle any local files. For example, they can

be edited, moved, or deleted:

If you would like to access files in the CMS via a web folder, the web folder needs to be created using

the Windows Explorer first. To do this and to be able to open this folder, you will need your login and

password. Use the CMS URL and append /DAV to it to create the web folder, for example:

http://the.server.com:8080/NPS/DAV with CMS Fiona 6.0.x or

http://the.server.com:8080/instance/NPS/DAV with CMS Fiona 6.5.x.
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After a web folder has been created, you can copy files it contains onto the desktop or into another

folder. You can edit the local copy and place it in the web folder again when you finished your work,

provided that your permissions are sufficient. Some applications (such as MS Word 2000) allow you to

open files directly from the web folder and also save them to this location

Since files in web folders do not have the same properties as files in the CMS, you should keep in mind

the following points when you access files via a web folder:

Important Notes about Working with Web Folders

In the following, files in the CMS are called "CMS files" and "CMS folders".

• In web folders, CMS folders are represented as folders. These folders must not have a file name

extension.

• CMS files other than folders are represented as files. A file corresponds to a draft version if the CMS

file concerned has a draft version. Otherwise the file corresponds to the released version.

• The name extension of files corresponds to the file name extension of the draft or the released

version, respectively. The file name extension can not be changed. It is also not possible to create a

file whose name differs only in the extension from a file already present in the folder. You can not,

for example, create a file named news.html if a file named news.shtml already exists.

• As a file is saved, the draft version of the CMS file concerned is overwritten. If the CMS file does not

have a draft version, it will be created. In order to be able to save a file, it is sufficient to have write

permission for the CMS file. The write operation causes you to become the editor of the version

even if it is being edited by another user.

• The contents of a CMS folder (main content and fields) is normally represented as the file

index.html in a folder that has the same name as the CMS folder. The name and the name

extension of this file are a matter of configuration and might have been changed by an

administrator. This file can not be deleted.

• A folder can only be deleted if it contains neither subfolders nor files. An exception to this rule is

the file that represents the contents of the CMS folder (normally index.html). You can delete a

folder which contains only this one file, provided that you are the administrator of this file or a

CMS administrator.

• When a file is copied, its name extension must not be changed. The file that represents the

contents of a folder (index.html) can not be copied.

• When a file is opened, it contains the main content of the version of the CMS file concerned.

Version fields are not transmitted.

• When an HTML file is saved, version fields are set in the same manner as if content is imported, i. e.

the META elements contained in the HTML text are evaluated and interpreted as version fields.

• The character encoding of a version is not modified when the version is read or saved. The

applications used to edit the main content of versions must store text files UTF-8-encoded.

• In file names only the characters A to Z, a to z, 0 to 9 and the underscore are permitted. Spaces are

converted to underscores. Names containing other characters are rejected.

File Selection and Error Messages

• The versions of the Windows operating system differ with respect to the methods they offer

for opening files in web folders. If, for example, you double-click a file in a web folder, it is

possible that nothing happens although the file name extension is associated with an application.

Furthermore, it can happen that files are always opened with the Internet Explorer or that files can

not be opened from within all applications.
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• It is always possible to copy a file from a web folder into an ordinary folder, optionally using drag

and drop. A file copied in this manner can be edited and subsequently copied back to the web

folder.

• If an error occurs, the Content Manager’s user interface transmits a corresponding error message

to Windows. These messages, however, are not displayed. Instead, a general message is displayed

saying that an operation could not be performed.

• If you edit versions by means of web folders and at the same time are logged into the CMS via the

browser, select Refresh from the View menu of the Content Navigator to make the changes visible

there.

Notes about Use on Windows Server 2003

Please install the current Software Update for Web Folders from Microsoft and set the system registry

key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services \WebClient\Parameters

\UseBasicAuth (DWORD) to 1.

http://support.microsoft.com/?kbid=892211
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12
12  The Integrated HTML Editor

Infopark CMS Fiona is supplied with an optional easy-to-use HTML editor you can open from the NPS

Navigator if Java is enabled in your browser. Using this editor, it is possible to edit the main content

of the draft versions or the values of HTML fields. The HTML Editor accepts only XHTML. This means

in particular that all tags must be written in lower case letters and that the tags must be closed. The

HTML editor is therefore not suited for editing complex layouts (in which, for example, tags are opend

and closed in different files.) The requirements of XHTML documents are described in detail at http://

www.w3.org/TR/xhtml1/.

You can open the HTML editor if you are the editor of the file currently selected in the NPS Navigator.

Furthermore, the administrator must have made the editor available for the file’s format. If these

conditions are met, the HTML Editor will be started automatically when you edit the main content of

the draft version. If several editos are available for editing, you can choose one from the Edit > Edit

main content with menu command or click the Edit with... button on the editor page. This applies

analogously when you edit the main content or an HTML field value directly via the preview, the

overview or a details tab.

The HTML editor has several text editing functions, links and images can be inserted comfortably:

The draft version’s HTML text that is to be edited appears in the text input area. You can modify the

text, enter and format new text and insert tables, images and links. The editor has two operating

modes. You can switch between them by using the button to the left-hand side below the input area.

In WYSIWYG mode, the display largely corresponds to the subsequent output in the browser. In HTML

mode, only the HTML text is displayed, i. e. images cannot be displayed or opened and text cannot be

formatted (the corresponding buttons are not available).

http://www.w3.org/TR/xhtml1/
http://www.w3.org/TR/xhtml1/
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With Fiona 6.6.1 and later, the content being edited can be saved to the draft version using the Save

button so that you can preview your changes without having to close the editor.

The functions of the buttons in the tool bar are described in the following overview:

Button Function

Reduce tool bar to one line or have it fully displayed.

Cuts the marked text and saves it to the editor’s clipboard.

Copy marked text and save it to the editor’s clipboard.

Paste text from the clipboard at the cursor position.

Opens a dialog with which text can be sarched an replaced.

Here you can select the heading level.

Here you can select the font.

Here you can select the font size.

Removes all text markups.

Enable/Disable bold style.

Enable/Disable italics style.

Enable/Disable underlined style.

Select a color using the color dialog box. This button then shows the color
selected.

Left-align paragraph.

Center paragraph.

Right-align paragraph.

Justify paragraph.

Subscript paragraph.

Superscript paragraph.

Inserts a table at the cursor position.

Inserts a table using the table wizard (the number of rows and columns can be
specified using the mouse).

Display paragraph as list element.
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Display paragraph as numbered list element.

Reduce indentation by one level.

Increase indentation by one level.

Insert a link.

Insert an image.

Inserts a horizontal rule.

Perform spelling check (see below).

Opens the character table from which a character can be chosen.

Enable/Disable display of control characters.

Specify default font, link and background color.

Opens the HTML editor in a separate window (without the surrounding NPS
layout).

Display information about the editor.

Please note that your changes will only be saved after clicking the OK button. If you click the Cancel or

the New Document button, all changes will be lost

12.1  Inserting a Link

In order to insert a link using the HTML editor, first mark the text or the image to be linked and then

click the Link button. The editor then opens a dialog box window with which you can define the link:

The form elements have the following meaning:

• Title: the value of the title attribute of the a tag generated. The title is optional. It might contain

a brief description of the contents of the link target.
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• Destination: the linked CMS file in the form of a CMS path, or an external URL (or mailto-, or file

URL). If the link destination is a CMS file, you can select it using the Content Navigator by clicking

the selection button. In the Navigator window select the desired file and click OK.

• Anchor: Optional name of an anchor, or an ID of an element in the destination file. The browser

will display the content to which the link points at the top of the browser window.

• Frame: If the file containing the link is part of a frame set: the name of the frame in which the

destination file is to be displayed. Select New window if you want the link target to be opened

in a new window. An empty frame name causes the destination file to be opened in the current

browser window.

Finish editing the link by clicking OK.

12.2  Inserting an Image

To insert an image into the HTML page, place the caret at the desired location and click the image

button in the tool bar. This will open a page on which the image can be specified. If an image is to be

replaced by a different image, select it before clicking the image button.

Enter the file path directly into the input field or use the selection button to specify the file using a

Content Navigator page. Here, select the desired file and click OK to accept its path. Click OK once

more on the previous page to finish the image selection.

12.3  Inserting and Editing Tables

 

Using the HTML Editor, you can insert and edit tables. A table can be created by clicking the table

creation button. The HTML editor then queries the table parameters such as the number of lines and

columns by means of a dialog and inserts a table with these parameters into the editor window. The

table parameters can still be altered later. They are explained below.

Using the table wizard you can determine the table size using the mouse.

can now enter text into the table cells and insert links and images. Several functions are available via

the context menu and its Table submenu, which can be opened via the second mouse button while the

mouse pointer is over the table:</p>
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Menu Command Function

Insert row Inserts a row above or below the row in which the cursor is currently
located.

Insert column Inserts a column left or right of the column in which the cursor is
currently located.

Merge Merges the active cell and one of its neighbor cells.

Split Splits the active cell into several cells.

Delete row Deletes the row in which the cursor is currently located.

Delete column Deletes the column in which the cursor is currently located.

Delete table Deletes the entire table.

Cell properties Edit dimensions, alignment and color of the active cell and define
whether it is a header cell.

Row properties Opens a dialog window in which the height, alignment, and color of
the row can be set in which the cursor is currently located.

Column properties Opens a dialog window in which the width, alignment, and color of
the column can be set in which the cursor is currently located.

Table properties Opens a dialog window in which the properties of the table can be
set.

12.3.1  Inserting Rows and Columns

In order to insert a row or a column, click with the second mouse button inside a cell of the

appropriate row or column and select the command Insert row or Insert column from the Table

submenu in context menu. The corresponding dialog box window then opens:

position of the new row or column, then click Insert row or Insert column.</p>

12.3.2  Changing Properties of Rows and Columns

If you would like to change the height of a row or the width of a column or the corresponding

background color, click with the second mouse button in a table cell of the respective row or column.

Select the command Row properties or Column properties from the Table submenu of the context

menu which then opens. The editor then opens a corresponding dialog box:

Here, you can enter the height of the row or the width of the column in pixels or percent or set the

alignment. The percentage values refer to the height and width of the browser windows. Additionally,

you can determine the background color of the row or column in a color dialog box by clicking on the

corresponding button. In order to accept your settings, click on OK.
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12.3.3  Changing Cell Properties

For each cell of a table the width and height, vertical adjustment and the background color can be

specified. Additionally, each cell can be tagged as a header cell which has the effect that the cell looks

differently (mostly a bold font is used). To change these values, click into any cell using the second

mouse button and select the Cell properties menu command from the Table submenu. The editor then

displays the following dialog:

On the Advanced sheet many other cell attributes can be defined or modified by entering the new

values directly into the property editor’s cell or selecting one of the preset values. Change the values as

desired and finally click OK.

12.3.4  Editing Table Properties

The properties of a table are, among others, the width of the table, the width of the table and cell

margins, and the distance of the cell contents to the cell borders. In order to change these values, click

on any table cell using the second mouse button and select the menu command Table properties from

the Table submenu. The editor then displays the following dialog box:

The table width can be entered in absolute values (pixels) or relative to the width of the browser

window (percent). You can also determine the border line width, the cell padding and the cell spacing

(all in pixels). On the Advanced sheet many other table attributes can be defined or modified by

entering the new values directly into the property editor’s cell or selecting one of the preset values.

Finally, click OK to accept the settings.
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12.4  Performing a Spelling Check

The HTML editor has a built-in spelling checker for texts in several languages. You perform a spelling

check by clicking the corresponding button in the toolbar of the HTML editor.

If the spelling checker does not find any unknown or questionable words, a corresponding message

is displayed. Otherwise, the questionable words are marked in the editor and a dialog box window

opens in which you can have it corrected or you can search for an alternative:

The input elements and buttons in this dialog box have the functions described in the following

overview:

Input Element Function

Not in Dictionary This entry field contains the current word to be checked.

Change / Change All The Change entry field contains the word the spelling checker
suggests as a replacement to the word not found in the dictionary.
Using the Change button, you can accept the replacement word
into the text in the HTML editor. The word marked in the editor is
overwritten. Using the Change All button, you can replace all the
instances of the corrected word.

Suggestions / Suggest The words the spelling checker has found as an alternative to the
word entered are displayed in the Suggestions list. If you enter a
different word in the entry field Not in dictionary and then click on
the button Suggest, the list is updated.

Ignore Ignores the word in question and continues with the spelling check.

Ignore All Ignores all instances of the word in question in the current text and
continues with the spelling check.

Dictionaries / Change The available dictionaries. Click Change after you have selected a
different dictionary.

Cancel Cancels the spelling check.
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The list of available spelling-checking dictionaries can be configured by a CMS administrator.

http://www.infopark.com/1214003/08-EOP-Config
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13
13  TinyMCE

TinyMCE is a WYSIWYG HTML editor available from within the user interface of Infopark CMS Fiona

6.8 and later. If the administrator has enabled the use of this editor, it can be opened via the Edit

menu (Edit main content with) or the details view for editing the main content. Using a wizard, the

editor can also be used for editing other HTML fields.

The editor offers the known functions for designing text and tables. Links pointing to CMS files

(folders, documents, images, and resources) or external sources can be inserted and edited by means of

CMS Fiona’s file selection dialog.
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14
14  Microsoft HTML Editor

The main content of a draft version as well as other HTML fields can be edited with several editors if

this has been configured accordingly by the administration. Up to CMS Fiona 6.7.3, Microsoft Internet

Explorer is one of the available editors. This browser has a mode in which HTML text can be edited. In

editing mode, the text is displayed almost as it appears after the file has been published.

After selecting in the Content Navigator a file whose format permits using Microsoft HTML Editor, you

can edit one of its HTML fields such as the main content using this editor. (Prior to this, it might be

necessary to perform a workflow action.)

To find the field to be edited switch to the details view and locate the field group containing the

field. Then click the field value to edit it. If a different editor is opened instead of Microsoft HTML

Editor, click Edit with... and choose Microsoft HTML Editor. (If the editor is not offered to you, the

administration has not permitted its use.)

The contents of the field concerned will appear in the text input area of the HTML editor. You can

modify the text, add and format new text as well as images and links. Links can be edited using the

dialog known from the Content Navigator.

With Fiona 6.6.1 and later, the content being edited can be saved to the draft version using the Save

button so that you can preview your changes without having to close the editor.

All functions are easily accessible via toolbar buttons or menus. The functions are described in the

following overview:

Button Menu command Function
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File - Save Saves the changes.

-- Here you can select the font size.

-- Here you can select the font.

Format - Font color Select font color. The button then shows the
color selected.

Format - Highlight Select text highlight color. The button then
shows the color selected.

Format - Bold Enable/Disable bold style.

Format - Italic Enable/Disable italic style.

Format - Underline Enable/Disable underlined style.

Format - Superscript Enable/Disable superscripted style.

Format - Subscript Enable/Disable subscripted style.

Edit - Cut Cuts the selected text and stores it in the
clipboard.

Edit - Copy Copies the selected text to the clipboard.

Edit - Paste Pastes text stored in the clipboard at the
caret position.

Edit - Delete Deletes the selected text or the character to
the right of the caret.

Edit - Undo Reverses the last action (if possible).

Edit - Redo Restores the last reversed modification.

-- Here you can select the heading level.

Format - Numbered list Display paragraph as numbered list element.

Format - Bullets Display paragraph as list element.

Insert - Link Insert or edit a link.

Insert - Image Insert an image.

Format - Decrease indent Decrease indentation by one level.

Format - Increase indent Increase indentation by one level.

Format - Align left Left-align paragraph.

Format - Center Center paragraph.
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Format - Align right Right-align paragraph.

In addition to the menu commands above the following commands (without corresponding buttons)

are available:

Menu command Function

Format -
Remove formatting

Removes the formatting from the selected text (without changing the
heading level, however)

Insert - Unlink Deletes the link associated with the text or image at the caret
position.

Insert -
Horizontal rule

Inserts a horizontal rule at the caret position.

Edit -
Reload editor

Redisplays the editor page in the browser.

Table -
Insert or edit table

Lets you edit the properties of a new table to be inserted at the
caret position or edit the properties of the table in which the caret is
located.

Table -
Insert row above/below

Inserts a row above/below the row in which the caret is located.

Table -
Insert column to the left/
right

Inserts a column to the left/right of the column in which the caret is
located.

Table -
Delete row

Deletes the table row, in which the caret is located.

Table -
Delete column

Deletes the table column, in which the caret is located.

14.1  Inserting and Editing Text Links

To insert a link into the editor, first select the text or image to be linked, then click the link button. The

editor then opens a dialog page in which the link can be defined:

You can manually enter a URL (also a mailto or file URL) or the path of the target file into the first

input field. Into the second input field you can enter an anchor name. A frame name can be entered
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into the third field. Alternatively you can select the New frame option, if the link target is to be

opened in a new frame. If the frame name is left empty, the link target will be opened in the current

browser window

If the link target is a file, you might also select its path using the Content Navigator. To do this, click

the selection button. Here, select the desired file and click OK to return to the previous page. On this

page, confirm your input by clicking OK .

14.2  Inserting and Editing Image Links

To insert an image into the HTML page, place the caret at the desired location and click the image

button in the tool bar. This will open a page on which the image can be specified. If an image is to be

replaced by a different image, select it before clicking the image button.

Enter the file path directly into the input field or use the selection button to select the image by means

of a Content Navigator window. Here, select the desired file and click OK, to accept its path. Click OK

once more on the previous page to finish the image selection.

14.3  Inserting and Editing Tables

14.3.1  Creating or Modifying a Table

You can create and edit tables using the MSIE editor by means of the Insert or edit table command in

the Table menu. This menu also includes commands that allow you add rows or columns to an existing

table as well as delete rows or columns from a table.

position in the text (but not into a table) and select the menu command mentioned above. This will

open a dialog in which you can specify the table properties:</p>

The parameters in the dialog above have the following meaning:

Table Parameters Meaning
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Table width The width of the table in pixels or percent. Please use the percent sign for
percent values. Example: 50%

Border width The width of the border surrounding the table.

Table position The horizontal alignment of the table in the HTML page.

Cell spacing The space between cells.

Cell padding The space between the text in a cell and the inner border of the cell.

Number of rows The number of rows of the new table.

Number of
columns

The number of columns of the new table.

Click OK, after you have specified the parameters of the table. Click on Cancel, if you decide not to

create a table.

In order to subsequently change the table properties, please place the caret in any cell of the table

concerned and again select the Insert or edit table command in the Table menu. This will also open the

dialog above. The parameters Number of rows and Number of columns, however, are missing. They are

only available when a new table is created.

Edit the table parameters as desired and finally click OK to continue editing the text.

14.3.2  Inserting and Deleting Rows and Columns

The Table menu of the Microsoft HTML editor includes several commands for adding or deleting rows

or columns to or from a table, respectively.

The Delete row and Delete column commands refer to the line or column, respectively, in which the

caret is located. The commands are executed immediately after they have been selected and cannot be

undone.

To delete the whole table, please select it first. Then delete it using the Delete key or by means of the

corresponding context menu command (if available).
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15
15  The Markdown Editor

From version 6.6 of CMS Fiona, content can be formatted using Markdown, a simple notation for

links and standard markup for lists, font styles, indented text and more. For Markdown content the

field type Markdown is available, which behaves like the HTML field type but is, additionally, able

to interpret Markdown markups. In the preview and on the live server (i.e. with exports), Markdown

markup is only taken into account if the Rails Connector for Infopark CMS Fiona is used.

Markdown-formatted content can be created and edited using the Markdown editor that is supplied

with Infopark CMS Fiona.

Enter your text using the Markdown syntax into the panel on the left-hand side. The effect of your

changes is immediately visible in the panel to the right. An overview of the Markdown syntax can be

found on the web, for example at http://daringfireball.net/projects/markdown/syntax.

http://www.infopark.com/1193631/01-Create
http://www.infopark.com/1768163/12-Rails-Connector
http://daringfireball.net/projects/markdown/syntax
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16
16  The Concepts of Fiona

This section describes how Infopark CMS Fiona manages your content, how content can be edited

and published. Furthermore, the interested user learns more about the automatic link management,

workflows, and user administration.

16.1  Files

In Infopark CMS Fiona, content is maintained by means of files. Just like files in the file system of a

computer, files in Fiona have names and are organized hierarchically in a tree structure. Each file

resides in a folder. After all, folders are files too. However, as a special feature, they can contain other

files.

The base folder is the origin of the file tree and is the only file not contained in a folder (it has no

parent).

When a folder is published, i. e. its contents are placed on the live server, all the files contained in it

are published as well.

16.1.1  File Types

Next to folders, four other file types exist, document, image, ressource, and layout. The type of a file

largely determines its purpose on your website; for example all images have the type image. The file

type determines how a file is published, as a binary file (image, resource) or a text file (document,

folder), for example.

In contrast to directories in a file system, folders can not only contain other files but also have content

themselves. After they have been published, they often function as initial or index pages, allowing you

to navigate to the subpages. Thus, their task is to structure content, not only in the editorial system

but also on the live server. Files of the document type, on the other hand, do not have this function.

They normally contain the actual textual content.
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Files of the image type can contain imported images of any kind. The images can be stored in the CMS

in the formats JPG, GIF, and PNG. Resources, on the other hand, can have any type of content. A file

imported as a generic document is usually offered to the visitor of your website for downloading (such

as PDF or ZIP files).

Layouts, finally, serve to give your website or parts of it a unified layout. They are not published but

control the way in which the contents of documents and folders appear on the web pages. Look at the

following illustration:

Layouts are the means by which a homogenous layout is given to your website.

16.1.2  File Creation Rules

Particular rules apply to the creation of files in the folder hierarchy. For example, to be able to create

a file in a folder, you require the file creation permission for this particular folder. Furthermore, the

file formats permitted in a folder might be restricted, meaning, for example, that it is not possible to

create a Newsletter file in a Press Releases folder.

16.1.3  Mirror Files

From version 6.5, files of all types can be inserted as mirror files at different locations into the folder

hierarchy to re-use their contents. When creating mirror files, the same rules as for original files apply.

16.2  Versions, Fields and Formats

In Infopark CMS Fiona, each file can have several versions, a draft version, a released version and any

number of archived versions. The draft version can be modified while the released version is meant to

be published and cannot be changed. When a draft version is released, it replaces the file’s released

version, if present, which in turn is archived, i. e. turned into an archived version. A file that neither has

a draft nor a released version is inactive.

http://www.infopark.com/1194029/05-Layouts
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A version is a set of fields that constitute the contents of the version. Analogous to the term body,

which denotes the main content of an HTML file, all versions of files have a field named main content.

Apart from this one, other fields exist, title, validFrom, and validUntil, for example. The fields

common to all versions can be found in section Version Fields.

A CMS administrator can create additional fields and add them to file formats to adapt these

formats to their specific purposes. This has the effect that every version of a file based on a particular

format has these fields assigned to it. To a format named PressRelease you might want to add an

abstract field, while a BusinessOffer might require a category field, for example.

Several field types are available. Each type is intended for values of a specific format (for example

dates, HTML texts, enumerations).

The administrator can have the values of fields checked automatically, by a script, for example, to

ensure that the values meet certain conditions. It can be checked, for example, whether a version

has a title whose length does not exceed a given number of characters or whether a number is in a

particular range.

The CMS considers the draft version of a file incomplete if it contains fields that do not meet the

specified conditions, or if it contains links that point to nonexistent files in the CMS. Incomplete draft

versions can neither be forwarded to other users or user groups for further editing nor can they be

released.

Not only the versions of file but also the files themselves have fields. File fields, however, only hold

administrative information, for example the file name, the file format, and the workflow to be used.

There are no custom file fields.

16.3  Validity Periods

Infopark CMS Fiona supports validity periods for the purpose of time-controlled file publishing. This is

achieved by means of corresponding version fields.

Initially, the validity period of a draft version begins at the time of its creation and is unlimited. You

can set the validity period by means of the fields validFrom and validUntil. If validUntil has not

been specified, the validity period has no end, meaning that the file is valid for an unlimited period of

time beginning at validFrom.

A temporally invalid file is not exported and links to this file are suppressed. Furthermore, individual

fields of the file cannot be accessed during the export, as opposed to files whose export is suppressed

(by means of the suppressExport field).

If the validity period of a file changes, the Template Engine automatically updates the exported files

concerned.

From Version 6.5.0

From version 6.5.0, CMS files can be removed from the live server. This process is called deactivation

and is controlled by the corresponding workflow.

Expired or deactivated files are displayed struck through in the Content Navigator and can also be

hidden. For further information, please refer to the document that describes the tree view.
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16.4  Workflows and Tasks

Infopark CMS Fiona supports typical working procedures of creating, verifying, and releasing files. For

this, workflows are provided.

In Fiona, a workflow is a sequence of editing and verification steps which refer to the draft version of a

file. Each step in a workflow is made by a member of exactly one user group.

As soon as a draft version of a file is created, the file appears in the task list of all members of the user

group that is to perform the first step. The user who has created the draft version becomes its editor.

A draft version is created by performing the edit workflow step. This step is performed automatically

when a field of the released version is edited an no draft version exists.

The current editor can give the file (hence the draft version) to every user who is a member of the

user group entitled to perform the workflow step. He can also give the version to a user who does not

belong to this user group. (Prior to version 6.5 the recipient of the file was required to have the write

permission for it.) However, the workflow step can only be performed by a user of the group specified

in the workflow for the step concerned. A user can take over a file, i. e. become the editor of its draft

version. For this, he needs to have the write permission for the file or again be a member of the user

group specified in the workflow for this step.

After each editing step the draft version is forwarded or committed, respectively, if the next step is

a verification step. A verification step is performed by signing the committed draft version. The last

verification step is the release.

A draft version can be rejected while it is edited or verified. This workflow step does not undo the

changes made to the draft version, however, the workflow needs to be passed through again from the

beginning.

Workflows are defined by a CMS administrator. A workflow definition has a name that can be

specified in file formats so that new files based on these formats are automatically subject to this

workflow. However, the workflow of a file can also be changed subsequently by setting the workflow

file field to a different workflow name. This can only be done by an administrator of the file or by a

CMS administrator.

16.5  Reminders

From version 6.5.0, Infopark CMS Fiona offers reminders. By means of a reminder an editor can be

notified about a file at a given time. This makes it easier to maintain content that needs to be updated

at regular intervals.

16.5.1  Setting Up a Reminder

Every file is associated with exactly one reminder which can be edited by users who have write

permission for the file. You can set up the reminder of a file by selecting the file in the Content

Navigator and then opening a dialog with which the recipient list, the due date, and optionally a

comment can be set. The dialog can be accessed via the Define Reminder menu command or by

clicking the Reminder field in the file overview:

http://www.infopark.com/1193724/03-Workflows
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16.5.2  Reminder E-Mail Notification

If the CMS administrator has enabled the automatic e-mail notification for reminders, each recipient in

the distribution list of a reminder will from the due date on receive an e-mail message informing him

about the file.

Users that do not want to receive these messages can deactivate them via the Send report as e-mail

option in their personal preferences.

16.5.3  Reminder Overview

By means of the Reminders menu command, every user of the CMS can have his own reminders

displayed and search for reminders that match particular search criteria. The reminders listed in the

dialog can be edited or deleted individually or as a selection.

16.6  Link Management

Infopark CMS Fiona includes automatic, bidirectional link management which helps you to focus on

your work with content instead of manually maintaining links. If a version field contains a link to a file,

the link is automatically updated the moment one of the two files is moved or renamed. By means of

the following mechanisms, link management ensures that the links of a web site produced with the

CMS are consistent:

• From version 6.5.0, the CMS can check whether the targets of external links can be reached.

Furthermore, you can unlink files directly, i.e. change all the links pointing to a specific file.

• Infopark CMS Fiona does not publish links to non-exportable files, i. e. files that are nonexistent,

incomplete or temporally invalid.

The CMS differentiates between several types of links:

• Links in the text (links in the main content and HTML fields) are links to other files managed by

Infopark CMS Fiona (internal links) or to files (web pages, images, etc.), which are not managed by

the CMS (external links). All the links (such as <img scr="...">) in your HTML code (i. e. in the

main content and in HTML fields) and in export instructions are maintained by link management.

• Free links are called free because they are not contained in text fields but in so-called link lists – a

special field type. They are used to associate the version to which they are assigned via the linklist

field with other files or web pages. When a version is published, its free links can be output as a

collection of links

The following link types are rather special. They are used primarily by designers.

• Inclusion link: It is possible to insert the main content of one version into the main content of

another version. This is done by means of the export instruction includetext, which the CMS

http://www.infopark.com/1480130/13-Reminders
http://www.infopark.com/1194755/14-npsobj-Syntax
http://www.infopark.com/1194848/includetext
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manages as a link. External web pages cannot be transferred into the main content of a version in

this way.

• Context links are generated by the system when the NPSOBJ- context instruction is used in a

layout to change the context, i. e. another file is temporarily made the current file.

• Dynamic links are generated from references specified in NPSOBJ-insertvalue- dynamiclink

instructions. Such instructions are used to generate code in the syntax of script languages.

In the Content Navigator, the links contained in the version currently displayed are listed in the details

view. These links can be modified separately on a dialog page.

16.7  User Administration and Permissions

Infopark CMS Fiona includes an easy-to-use user administration. Every user receives a log-in name, a

login. A login is a unique identification which "embodies" the user. Each login is assigned a password,

which the user must enter to be able to work with Fiona.

Using the user administration, the CMS administrators can create user groups and allocate users to

groups. After the login of a user has been set up, he or she automatically becomes a member of a

default user group. He or she can be a member of any number of groups. Using global permissions, an

administrator can define the authorizations the users and groups have with regard to administrative

tasks.

User groups fulfill an important task, also with regard to files. On the one hand, administrators can

define user groups to determine which employees may edit, verify and release files. On the other

hand, the groups can be granted file-specific permissions. In this way, for each file the administrator

can define how the members of a group can access files. For example, a user (via one of the groups in

which he or she is a member) must have administration permission for a file to be able to delete the

file; to be able to change the field values of its draft version, he or she requires write permission.

File-specific permissions cannot be granted to individual users, but only to user groups. The following

permissions can be granted for each file:

• Read Permission

Permits all kinds of access to the file that does not change it. For example, the preview or the file’s

details can be viewed in the Content Navigator.

• Write Permission

Permits creating as well as editing a new draft version (this also includes changing field values).

Users who have been granted write permission automatically have read permission.

• File Creation Permission

This permission can only be granted for folders. This permission allows its possessor to create files

in the respective folder. To be able to create a file using a specific format it might be necessary to

additionally have a global permission defined by the administrator. (The administrator can restrict

using a format to users who have a particular permission he has defined.)

• Administration Permission

Users to whom this permission has been granted possess all authorizations with respect to the

file concerned. The administration permission is required to delete, rename or move files, as well

as to be able to unrelease them. As the administrator of a file you have permission to release it

regardless of its editing status.

• Live Server Read Permission

This permission can be given to user groups to allow them to access the published file concerned.

The groups to whom this permission can be granted may be different from those for the other

permissions (they optionally originate from a different user management). If a file’s live server read

http://www.infopark.com/1194806/context
http://www.infopark.com/1194884/insert-dynamiclink


The Concepts of Fiona

Editing Content – © 2011 Infopark AG 100/101

permission has been assigned to at least one user group, only the respective group members are

permitted to access the document concerned. Otherwise, all visitors may access it. This permission is

only available in conjunction with the Portal Manager.

When you create a file, the permissions assigned to the folder containing it apply to the file as well

(the file "inherits" the permissions of this folder). If these permissions do not include the read and

write permission, the CMS automatically grants the missing file-specific permissions to your default

group so that users who have created a file can edit its draft version. Users who have created a file can

delete it as long as it has not been released. After the release the administration permission is required

for this.

Permissions are not inherited retroactively. If, for example, you are granted the administration

permission for the folder containing your file, your file's permissions remain unaffected by this.

16.8  Mirror Files

16.8.1  Tasks and Usage

From version 6.5.0, Infopark CMS Fiona supports so-called mirror files, however, not if the Rails

Connector for CMS Fiona is used. By means of mirror files, content can be used in several places of the

folder hierarchy. In particular, mirror files allow the contents of a file to be exported using several

layouts.

A mirror file has no content by its own and thus no version fields. When it is displayed or edited, the

contents of the original file is always used. This also applies analogously to its file fields, except for the

following ones:

• the file name (name),

• the folder containing the file (parent),

• the permissionRoot permission

Thus, if one of these fields is modified in the original file, the mirror files are not affected by this (and

vice versa). If, on the other hand, a different field is modified, it is modified in the mirror files as well.

When mirror files are created, the same rules as for other files apply. However, the user must also have

the global permissionGlobalMirrorHandling permission. Furthermore, the mirror file inherits its

administration permission (permissionRoot) from the permissionCreateChildren permission of

the folder containing the mirror file. This ensures that a user who creates a mirror file is also permitted

to rename or to delete it.

A file of which one ore more mirror files exist, cannot be deleted. The relationship between a file and

its mirror files is not affected if one of the files is moved to another place in the folder hierarchy.

If a folder is mirrored, its folder hierarchy is completely mirrored as well. It is not possible to create files

in a mirror folder or its subfolders.

16.8.2  Automatic Update of Mirror Folders

If a file is created in an original folder (i.e. in a folder that is no mirror file), the mirrored folders

automatically contain the corresponding mirror files. Example:

http://www.infopark.com/1768163/12-Rails-Connector
http://www.infopark.com/1768163/12-Rails-Connector
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The folder hierarchy above was created in the following way:

• internal and external were created manually.

• external/news was created manually as well.

• external/news was copied into the clipboard.

• internal was selected.

• The contents of the clipboard was pasted as mirror file so that internal/news now is a mirror file.

• Then external/news/article-01 was created manually.

• The system has automatically created the mirror file external/news/article-01.

If there are several mirror folders (of the folder external/news in the example above) exist, a mirror

file appears in each of them if a file is added to the original folder.

All the operations made in an original folder or its subhierarchy (such as deleting or copying files) are

also effective its mirrored folders.
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